summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParker Reed2019-09-22 21:56:52 -0400
committerParker Reed2019-09-22 21:56:52 -0400
commit20eadac225783b4f5f0d0986555a858b482d68e9 (patch)
tree784efc5ac7e397823e0478aa963499f433210650
downloadaur-20eadac225783b4f5f0d0986555a858b482d68e9.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4c7d122c508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = joycond-git
+ pkgdesc = Userspace daemon to combine joy-cons from the hid-joycon kernel driver
+ pkgver = r31.a7dcddd
+ pkgrel = 1
+ url = https://github.com/DanielOgorchock/joycond
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ provides = joycond-git
+ conflicts = joycond-git
+ source = git+https://github.com/DanielOgorchock/joycond.git
+ md5sums = SKIP
+
+pkgname = joycond-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6c3af526af8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Parker Reed <parker.l.reed@gmail.com>
+
+pkgname=joycond-git
+pkgver=r31.a7dcddd
+pkgrel=1
+pkgdesc='Userspace daemon to combine joy-cons from the hid-joycon kernel driver'
+arch=('any')
+url='https://github.com/DanielOgorchock/joycond'
+license=('GPL3')
+makedepends=('cmake' 'git')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+source=('git+https://github.com/DanielOgorchock/joycond.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/joycond"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/joycond"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$srcdir/joycond"
+ make DESTDIR="$pkgdir/" install
+ mv "$pkgdir/lib" "$pkgdir/usr/"
+}