summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Waś2018-04-13 15:04:58 +0200
committerJan Waś2018-04-13 15:04:58 +0200
commit69dfe9e8202b9d48b6cfeec6bc01e2f6786e4807 (patch)
tree2b37c0da42235e582bf1c956de3a354044749c19
downloadaur-69dfe9e8202b9d48b6cfeec6bc01e2f6786e4807.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e856bffb13d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = jp
+ pkgdesc = Command line interface to JMESPath
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = http://jmespath.org
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = jp::git+https://github.com/jmespath/jp#tag=0.1.3
+ sha512sums = SKIP
+
+pkgname = jp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5709bdf2c03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jan Waś <janek.jan at gmail com>
+
+pkgname=jp
+pkgver=0.1.3
+pkgrel=1
+pkgdesc='Command line interface to JMESPath'
+arch=('x86_64')
+url='http://jmespath.org'
+license=('Apache')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=('jp::git+https://github.com/jmespath/jp#tag=0.1.3')
+sha512sums=('SKIP')
+
+build() {
+ tempgopath="$(pwd)/go"
+ jppath="${tempgopath}/src/github.com/jmespath"
+ fakerepo="$jppath/jp"
+ mkdir -p $jppath
+ ln -s "$(pwd)/${pkgname}" "$jppath/jp"
+ export GOPATH="$tempgopath"
+ cd "$fakerepo"
+ go build
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: