summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Martyanoff2023-11-17 14:32:02 +0100
committerNicolas Martyanoff2023-11-17 14:32:02 +0100
commitca6a4a9413f7db6e0383c27312b1be20debd9692 (patch)
treef73cc6d0296ec5d1a99eda6f040f844425c37219
parent18720b8e05ad25dcbbca33857f31fd72aa61500e (diff)
downloadaur-ca6a4a9413f7db6e0383c27312b1be20debd9692.tar.gz
update to 0.2.1
-rw-r--r--PKGBUILD47
1 files changed, 23 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index beef4a3a3f40..4ce7c95ebc9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Maintainer: Jan Waś <janek.jan at gmail com>
+# Maintainer: Nicolas Martyanoff <nicolas@n16f.net>
-pkgname=jp
-pkgver=0.2.0
-pkgrel=1
-pkgdesc='Command line interface to JMESPath'
-arch=('x86_64')
-url='http://jmespath.org'
-license=('Apache')
-makedepends=('go' 'git')
-options=('!strip' '!emptydirs')
-source=('jp::git+https://github.com/jmespath/jp#tag=0.2.0')
-sha512sums=('SKIP')
+pkgname="jp"
+pkgver="0.2.1"
+pkgrel="1"
+pkgdesc="Command line interface to JMESPath"
+arch=("x86_64")
+url="https://github.com/jmespath/jp"
+license=("Apache")
+makedepends=("go" "git")
+options=("!strip" "!emptydirs")
+source=("jp::git+https://github.com/jmespath/jp#tag=0.2.1")
+sha512sums=("SKIP")
build() {
- tempgopath="$(pwd)/go"
- jppath="${tempgopath}/src/github.com/jmespath"
- fakerepo="$jppath/jp"
- mkdir -p $jppath
- ln -s "$(pwd)/${pkgname}" "$jppath/jp"
- export GOPATH="$tempgopath"
- cd "$fakerepo"
- go build
+ tempgopath="$(pwd)/go"
+ jppath="${tempgopath}/src/github.com/jmespath"
+ fakerepo="$jppath/jp"
+ mkdir -p $jppath
+ ln -s "$(pwd)/${pkgname}" "$jppath/jp"
+ export GOPATH="$tempgopath"
+ cd "$fakerepo"
+ go build
}
package() {
- cd "${pkgname}"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: