summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Porquet2015-06-25 16:20:53 -0400
committerJoel Porquet2015-06-25 16:20:53 -0400
commitc381d516181f78c79b674c9d9a96d56c76ad5fcc (patch)
tree008a7e359cb8a7b1d7af7e111f41c05fb8655af1
downloadaur-c381d516181f78c79b674c9d9a96d56c76ad5fcc.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..227bc41a6c5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = jpass-git
+ pkgdesc = JPass password manager
+ pkgver = r16.4d491bc
+ pkgrel = 1
+ url = https://joel.porquet.org/wiki/hacking/jpass/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-configobj
+ source = jpass-git::git+https://joel.porquet.org/cgit/cgit.cgi/jpass.git/
+ md5sums = SKIP
+
+pkgname = jpass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43e01879d366
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Joël Porquet <joel@porquet.org>
+
+pkgname=jpass-git
+pkgver=r16.4d491bc
+pkgrel=1
+pkgdesc="JPass password manager"
+url="https://joel.porquet.org/wiki/hacking/jpass/"
+arch=('any')
+license=('GPL3')
+depends=('python' 'python-configobj')
+makedepends=('git')
+
+source=("${pkgname}::git+https://joel.porquet.org/cgit/cgit.cgi/jpass.git/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname}
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}