summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Porquet2015-06-25 16:23:02 -0400
committerJoel Porquet2015-06-25 16:23:02 -0400
commit51d6a55c3d7c9ab9c9e7986cc6a326f9ab5ff54a (patch)
treede81b2f520a4637a014d32be21266e7214d0bd7f
downloadaur-51d6a55c3d7c9ab9c9e7986cc6a326f9ab5ff54a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD53
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..937c810b81fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = jpass-web-git
+ pkgdesc = JPass password manager - web application
+ pkgver = r13.62e6c07
+ pkgrel = 1
+ url = https://joel.porquet.org/wiki/hacking/jpass-web/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = jpass-git
+ depends = python
+ depends = python-bottle
+ depends = python-flup-hg
+ backup = etc/webapps/jpass/jpassrc
+ source = jpass-web-git::git+https://joel.porquet.org/cgit/cgit.cgi/jpass-web.git/
+ md5sums = SKIP
+
+pkgname = jpass-web-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6c09e2f4229
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Joël Porquet <joel@porquet.org>
+
+pkgname=jpass-web-git
+pkgver=r13.62e6c07
+pkgrel=1
+pkgdesc="JPass password manager - web application"
+url="https://joel.porquet.org/wiki/hacking/jpass-web/"
+arch=('any')
+license=('GPL3')
+depends=('jpass-git' 'python' 'python-bottle' 'python-flup-hg')
+makedepends=('git')
+
+backup=('etc/webapps/jpass/jpassrc')
+
+source=("${pkgname}::git+https://joel.porquet.org/cgit/cgit.cgi/jpass-web.git/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname}
+ _instdir="$pkgdir"/usr/share/webapps/jpass
+ _etcdir="$pkgdir"/etc/webapps/jpass
+
+ # web application
+ install -d "$_instdir"
+
+ install -m 0555 *.py "$_instdir/"
+
+ install -d "$_instdir/static/css"
+ install -d "$_instdir/static/js"
+
+ install -m 0444 static/css/*.css "$_instdir/static/css"
+ install -m 0444 static/js/*.js "$_instdir/static/js"
+
+ install -d "$_instdir/views"
+
+ install -m 0444 views/*.tpl "$_instdir/views"
+
+ # git hook generator
+ install -d "$pkgdir/usr/bin"
+
+ install -m 0555 bin/jpass_hook "$pkgdir/usr/bin/"
+
+ # config file
+ install -d "$_etcdir"
+
+ install -m 0444 docs/jpassrc.example "$_etcdir/jpassrc"
+ ln -s /etc/webapps/jpass/jpassrc "$_instdir/jpassrc"
+}