summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Schichtel2021-04-05 22:57:30 +0200
committerPhillip Schichtel2021-04-05 22:57:30 +0200
commite33729014d619d36e1cb8925760210d15c0b06dd (patch)
treeb79cf43a5cd4bb77f68d3e8fa1efb7ea196eae4b
parentccfe64df35b283ca1a9d1ba4f688776382403f8c (diff)
downloadaur-e33729014d619d36e1cb8925760210d15c0b06dd.tar.gz
update to 12.0.2
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD13
4 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f55ce1bc79e5..6a8729ff8fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = jprofiler
pkgdesc = The Award-Winning All-in-One Java Profiler
- pkgver = 11.1.4
+ pkgver = 12.0.2
pkgrel = 1
url = http://jprofiler.com
arch = any
license = custom
depends = java-environment
options = !strip
- source = https://download-gcdn.ej-technologies.com/jprofiler/jprofiler_linux_11_1_4.tar.gz
+ source = https://download-gcdn.ej-technologies.com/jprofiler/jprofiler_linux_12_0_2.tar.gz
source = jprofiler.desktop
source = jprofiler.sh
- sha256sums = 985bb23d6686d719a5eb6a592efd0dfa35aa385be7411dd61791594d1ff5a524
+ sha256sums = de486a863564b64ecbceefbf9663ad8af8d3ca9e601952cd529a49b2bcc7581b
sha256sums = be6fce730c9be07ca3574c1a390f93d54d8e9ab4a18233f97bc25273beacd33a
sha256sums = ccd3b8ffdefc25f5845263f087776153ec5269a68fe65970fe92e68e1dcf7e36
diff --git a/.gitignore b/.gitignore
index 0a2223f3641d..d6d6cb985138 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
src/
pkg/
diff --git a/Makefile b/Makefile
index 8a4aaa0957fa..d7491c691f19 100644
--- a/Makefile
+++ b/Makefile
@@ -9,4 +9,4 @@ package: PKGBUILD .SRCINFO
all: package
clean:
- rm -Rv .SRCINFO *.tar.gz *.tar.xz src/ pkg/ 2> /dev/null || true
+ rm -Rv .SRCINFO *.tar.gz *.tar.xz *.tar.zst src/ pkg/ 2> /dev/null || true
diff --git a/PKGBUILD b/PKGBUILD
index 5c045785e532..ed39be224bfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Phillip Schichtel <phillip.public@schich.tel>
pkgname=jprofiler
-pkgver=11.1.4
+pkgver=12.0.2
pkgrel=1
options=(!strip)
pkgdesc="The Award-Winning All-in-One Java Profiler"
@@ -11,7 +11,7 @@ depends=('java-environment')
source=("https://download-gcdn.ej-technologies.com/jprofiler/jprofiler_linux_$(echo $pkgver | sed 's/\./_/g').tar.gz"
"${pkgname}.desktop"
"${pkgname}.sh")
-sha256sums=('985bb23d6686d719a5eb6a592efd0dfa35aa385be7411dd61791594d1ff5a524'
+sha256sums=('de486a863564b64ecbceefbf9663ad8af8d3ca9e601952cd529a49b2bcc7581b'
'be6fce730c9be07ca3574c1a390f93d54d8e9ab4a18233f97bc25273beacd33a'
'ccd3b8ffdefc25f5845263f087776153ec5269a68fe65970fe92e68e1dcf7e36')
@@ -37,11 +37,10 @@ package() {
mv "${target}/license.txt" "$licensedir"
mv "${target}/license.html" "$licensedir"
- local image_var="plfd3t"
-
- cp "${target}/.install4j/i4j_extf_3_${image_var}_u9lgq5@2x.png" "${hicolor}/64x64/apps/${pkgname}.png"
- cp "${target}/.install4j/i4j_extf_3_${image_var}_u9lgq5.png" "${hicolor}/32x32/apps/${pkgname}.png"
- cp "${target}/.install4j/i4j_extf_2_${image_var}_1u8i2ka.png" "${hicolor}/16x16/apps/${pkgname}.png"
+ local image_var="dcmbrc"
+ cp "${target}/.install4j/i4j_extf_5_${image_var}_u9lgq5@2x.png" "${hicolor}/64x64/apps/${pkgname}.png"
+ cp "${target}/.install4j/i4j_extf_5_${image_var}_u9lgq5.png" "${hicolor}/32x32/apps/${pkgname}.png"
+ cp "${target}/.install4j/i4j_extf_4_${image_var}_1u8i2ka.png" "${hicolor}/16x16/apps/${pkgname}.png"
local appsdir="${pkgdir}/usr/share/applications"
install -dm755 "$appsdir"