summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Schichtel2016-07-28 00:18:50 +0200
committerPhillip Schichtel2016-07-28 00:18:50 +0200
commit58c12668f9942e1ab28608499277398ffe456bf8 (patch)
tree19fb43129f4fe7af2fc61a8d4803f1cefcd7bd09
parentfa21c79c60aea0a02c790aac1e5cf761749aee50 (diff)
downloadaur-58c12668f9942e1ab28608499277398ffe456bf8.tar.gz
updated to 9.2
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD8
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95407c14f643..4e68bdd61946 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Sun Apr 10 21:42:23 UTC 2016
+# Wed Jul 27 22:16:36 UTC 2016
pkgbase = jprofiler
pkgdesc = The Award-Winning All-in-One Java Profiler
- pkgver = 9.1.1
+ pkgver = 9.2
pkgrel = 1
url = http://jprofiler.com
arch = any
license = custom
depends = java-environment
- source = http://download-keycdn.ej-technologies.com/jprofiler/jprofiler_linux_9_1_1.tar.gz
+ source = http://download-keycdn.ej-technologies.com/jprofiler/jprofiler_linux_9_2.tar.gz
source = jprofiler.desktop
sha256sums = 46756992b5f004a0d5043b9dd74c1813cb0cf7752371492c4a41d1d1bf8bb1b0
sha256sums = be6fce730c9be07ca3574c1a390f93d54d8e9ab4a18233f97bc25273beacd33a
diff --git a/Makefile b/Makefile
index 2d47ed3c5e54..dfc5364a639b 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,8 @@
mksrcinfo
package: PKGBUILD .SRCINFO
- makepkg --force --clean
+ updpkgsums
+ makepkg --syncdeps --rmdeps --force --clean --noconfirm
all: package
diff --git a/PKGBUILD b/PKGBUILD
index fcf5c4935719..42c8a63e2cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Phillip Schichtel <phillip.public@schich.tel>
pkgname=jprofiler
_majver='9'
-pkgver="${_majver}.1.1"
+pkgver="${_majver}.2"
pkgrel=1
pkgdesc="The Award-Winning All-in-One Java Profiler"
arch=(any)
@@ -10,8 +10,8 @@ license=('custom')
depends=('java-environment')
source=("http://download-keycdn.ej-technologies.com/jprofiler/jprofiler_linux_$(echo $pkgver | sed 's/\./_/g').tar.gz"
"${pkgname}.desktop")
-sha256sums=(46756992b5f004a0d5043b9dd74c1813cb0cf7752371492c4a41d1d1bf8bb1b0
- be6fce730c9be07ca3574c1a390f93d54d8e9ab4a18233f97bc25273beacd33a)
+sha256sums=('ce393543e21a0b6501d9dd105740a3b48e73e954a4ca4d8cff2c02c1c1ba3a6b'
+ 'be6fce730c9be07ca3574c1a390f93d54d8e9ab4a18233f97bc25273beacd33a')
package() {
optdir="/opt/${pkgname}"
@@ -19,7 +19,7 @@ package() {
extracted="${srcdir}/jprofiler${_majver}"
install -dm755 "$target"
install -dm755 "${pkgdir}/usr/bin"
- cp -dpr --no-preserve=ownership "${extracted}/." -d "$target"
+ cp -dpr --no-preserve=ownership "${extracted}/." "$target"
ln -s "${optdir}/bin/jprofiler" "${pkgdir}/usr/bin/${pkgname}"
install -dm755 "${pkgdir}/etc"