summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordavronkhandamov2023-12-20 22:52:18 +0500
committerdavronkhandamov2023-12-20 22:52:18 +0500
commitc186f323116ba159664b8c344a4198cff1c5871b (patch)
treecced4bc70c158ba2ad18283e4f47ce60d7786fad
downloadaur-c186f323116ba159664b8c344a4198cff1c5871b.tar.gz
jprq first upload to aur.archlinux.org
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72e3063f55e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,9 @@
+pkgbase = jprq
+ pkgdesc = This is a free and open tool for exposing local servers to public network (the internet)
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://github.com/azimjohn/jprq/releases/download/2.2/jprq-darwin-amd64
+ arch = any
+ license = MIT
+
+pkgname = jprq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c626f6693eca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Davron <xamdamovdavron6@gmail.com>
+pkgname='jprq'
+pkgver=2.2
+pkgrel=1
+epoch=
+pkgdesc="This is a free and open tool for exposing local servers to public network (the internet)"
+arch=('any')
+license=('MIT')
+url="https://github.com/azimjohn/jprq/releases/download/2.2/jprq-darwin-amd64"
+
+build() {
+ set -e
+
+ URL_PREFIX="https://github.com/azimjohn/jprq/releases/download/2.2"
+
+ case "$(uname -sm)" in
+ "Darwin $CARCH") FILENAME="jprq-darwin-amd64" ;;
+ "Darwin $CARCH") FILENAME="jprq-darwin-arm64" ;;
+ "Linux $CARCH") FILENAME="jprq-linux-amd64" ;;
+ "Linux $CARCH") FILENAME="jprq-linux-386" ;;
+ *) echo "Unsupported architecture: $(uname -sm)" >&2; exit 1 ;;
+ esac
+
+ echo "Downloading $FILENAME from github releases"
+ if ! curl -sSLf "$URL_PREFIX/$FILENAME" -o "jprq"; then
+ echo "Failed to write to $INSTALL_DIR; try with sudo" >&2
+ exit 1
+ fi
+
+ echo "jprq is successfully installed"
+}
+
+package() {
+ install -Dm755 ./jprq "$pkgdir/usr/bin/jprq"
+}