summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuba Serafinowski2011-05-08 12:18:56 +0200
committerKuba Serafinowski2011-05-08 12:18:56 +0200
commit987975d9767306c90b9c8d575901ee713ce9c540 (patch)
tree3661856327361f17434422a300dd17ae87287a8f
downloadaur-987975d9767306c90b9c8d575901ee713ce9c540.tar.gz
add jreen-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29872cdc91f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = jreen-git
+ pkgdesc = Qt XMPP library
+ pkgver = 20110508
+ pkgrel = 1
+ url = http://gitorious.org/jreen
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake>=2.6
+ depends = libidn
+ depends = qca
+ depends = zlib
+ provides = jreen
+ conflicts = jreen
+ options = !strip
+
+pkgname = jreen-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51585eecb4fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Kuba Serafinowski <zizzfizzix(at)gmail(dot)com>
+
+##############################################################
+#### The section below can be adjusted to suit your needs ####
+##############################################################
+
+# What type of build do you want?
+# See http://techbase.kde.org/Development/CMake/Addons_for_KDE#Buildtypes to check what is supported.
+# Default is RelWithDebInfo to help with debugging.
+
+_buildtype="RelWithDebInfo"
+
+##############################################################
+
+pkgname=jreen-git
+pkgver=20110508
+pkgrel=1
+pkgdesc="Qt XMPP library"
+arch=('i686' 'x86_64')
+url="http://gitorious.org/jreen"
+license=('GPL2')
+depends=('libidn' 'qca' 'zlib')
+makedepends=('git' 'cmake>=2.6')
+provides=('jreen')
+conflicts=('jreen')
+options=(!strip)
+
+_gitroot="git://gitorious.org/jreen/jreen.git"
+_gitname="jreen"
+
+build() {
+ cd ${srcdir}
+ msg "Connecting to GIT server..."
+
+ if [ -d ${_gitname} ]; then
+ cd ${_gitname} && git pull origin
+ else
+ git clone --depth 1 ${_gitroot}
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf ${srcdir}/${_gitname}-build
+ cp -r ${srcdir}/${_gitname} ${srcdir}/${_gitname}-build
+ cd ${srcdir}/${_gitname}-build
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=${_buildtype}
+ make
+}
+
+package() {
+ cd ${srcdir}/${_gitname}-build
+ make DESTDIR=${pkgdir} install
+}