summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblackhole2015-06-08 22:57:03 +0200
committerblackhole2015-06-08 22:57:03 +0200
commitb52b8d06fe1ddff8cff08ffec614b0b003f45315 (patch)
tree3a51f3b9deb2e8d6a327b61540b710b6e5dc494a
downloadaur-b52b8d06fe1ddff8cff08ffec614b0b003f45315.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--License.txtbin0 -> 43222 bytes
-rw-r--r--PKGBUILD22
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccbd504a5978
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = jriver-media-center
+ pkgdesc = The Most Comprehensive Media Software
+ pkgver = 20.0.110
+ pkgrel = 1
+ url = http://www.jriver.com/
+ arch = x86_64
+ license = custom
+ depends = lib32-alsa-lib
+ depends = lib32-gcc-libs
+ depends = lib32-libx11
+ depends = lib32-libxcb
+ depends = lib32-libxau
+ depends = lib32-libxdmcp
+ depends = lib32-util-linux
+ depends = lib32-libxext
+ depends = lib32-gtk2
+ depends = lib32-p11-kit
+ optdepends = lib32-mesa-libgl: nouveau video support
+ optdepends = lib32-nvidia-libgl: nvidia video support
+ optdepends = xorg-fonts-75dpi:
+ optdepends = xorg-fonts-100dpi:
+ optdepends = vorbis-tools:
+ optdepends = lame:
+ optdepends = musepack-tools:
+ source = http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-20.0.110.deb
+ source = License.txt
+ sha256sums = 60c6e0816a47fb1d7f8b42b6ce53d68bf22cd8a7757a668d488425c20409ed4f
+ sha256sums = ee00f430918df6be37777a61e12812875b5583379c78daaa969bae7383a41fbd
+
+pkgname = jriver-media-center
+
diff --git a/License.txt b/License.txt
new file mode 100644
index 000000000000..e6c7194e3070
--- /dev/null
+++ b/License.txt
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1b953ca4f77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+# Contributor: Doug Newgard <scimmia at archlinux dot info>
+
+pkgname=jriver-media-center
+_debpkgver=20.0.110
+pkgver=$_debpkgver
+pkgrel=1
+pkgdesc="The Most Comprehensive Media Software"
+arch=('x86_64')
+url="http://www.jriver.com/"
+license=('custom')
+depends=('lib32-alsa-lib' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-libxcb' 'lib32-libxau' 'lib32-libxdmcp' 'lib32-util-linux' 'lib32-libxext' 'lib32-gtk2' 'lib32-p11-kit')
+optdepends=('lib32-mesa-libgl: nouveau video support' 'lib32-nvidia-libgl: nvidia video support' 'xorg-fonts-75dpi:' 'xorg-fonts-100dpi:' 'vorbis-tools:' 'lame:' 'musepack-tools:')
+source=("http://files.jriver.com/mediacenter/channels/v20/latest/MediaCenter-$_debpkgver.deb" 'License.txt')
+sha256sums=('60c6e0816a47fb1d7f8b42b6ce53d68bf22cd8a7757a668d488425c20409ed4f' 'ee00f430918df6be37777a61e12812875b5583379c78daaa969bae7383a41fbd')
+
+package() {
+ cd "$srcdir"
+ bsdtar xf data.tar.xz -C "$pkgdir"
+ install -Dm644 "License.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}