summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblackhole2019-03-23 00:03:23 +0100
committerblackhole2019-03-23 00:03:23 +0100
commit3d14413165edcf369c6bc1eaa2afba4cac0097a1 (patch)
tree361f363d8dab082c255d1655f58906160cd7a59b
downloadaur-3d14413165edcf369c6bc1eaa2afba4cac0097a1.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--License.txtbin0 -> 43222 bytes
-rw-r--r--PKGBUILD22
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53db1ead3b21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = jriver-media-center25
+ pkgdesc = The Most Comprehensive Media Software
+ pkgver = 25.0.15
+ pkgrel = 1
+ url = http://www.jriver.com/
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = libx11
+ depends = libxext
+ depends = libxcb
+ depends = libxau
+ depends = libxdmcp
+ depends = util-linux
+ depends = libxext
+ depends = gtk3
+ depends = webkit2gtk
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = gst-plugins-base-libs
+ depends = gst-plugins-good
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ optdepends = mesa-libgl: nouveau video support
+ optdepends = nvidia-libgl: nvidia video support
+ optdepends = vorbis-tools
+ optdepends = musepack-tools
+ conflicts = jriver-media-center
+ conflicts = jriver-media-center24
+ source = http://files.jriver.com/mediacenter/channels/v25/latest/MediaCenter-25.0.15-amd64.deb
+ source = License.txt
+ sha256sums = SKIP
+ sha256sums = ee00f430918df6be37777a61e12812875b5583379c78daaa969bae7383a41fbd
+
+pkgname = jriver-media-center25
+
diff --git a/License.txt b/License.txt
new file mode 100644
index 000000000000..e6c7194e3070
--- /dev/null
+++ b/License.txt
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0001a4fdb44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+
+pkgname=jriver-media-center25
+_debpkgver=25.0.15
+pkgver=25.0.15
+pkgrel=1
+pkgdesc="The Most Comprehensive Media Software"
+arch=('x86_64')
+url="http://www.jriver.com/"
+license=('custom')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxext' 'libxcb' 'libxau' 'libxdmcp' 'util-linux' 'libxext' 'gtk3' 'webkit2gtk' 'gstreamer' 'gst-plugins-base' 'gst-plugins-base-libs' 'gst-plugins-good' 'gst-plugins-ugly' 'gst-libav')
+optdepends=('mesa-libgl: nouveau video support' 'nvidia-libgl: nvidia video support' 'vorbis-tools' 'musepack-tools')
+conflicts=('jriver-media-center' 'jriver-media-center24')
+source=("http://files.jriver.com/mediacenter/channels/v25/latest/MediaCenter-$_debpkgver-amd64.deb" 'License.txt')
+sha256sums=('SKIP' 'ee00f430918df6be37777a61e12812875b5583379c78daaa969bae7383a41fbd')
+
+package() {
+ cd "$srcdir"
+ bsdtar xf data.tar.xz -C "$pkgdir"
+ install -Dm644 "License.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}