summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2021-03-16 17:23:37 -0400
committereshrh2021-03-16 17:23:37 -0400
commit03622cacb1197f344f0ea07e036f7593d59309a2 (patch)
treea33ecf6a9d0df258e4b1583df2db011681f30e04
parentd60b8cf87d0c80e931d92aecfc06cf80080011d9 (diff)
downloadaur-03622cacb1197f344f0ea07e036f7593d59309a2.tar.gz
quiet behave and black
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e0ec8b14e5f..5dc90dce4e47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = jrnl-git
pkgdesc = Collect your thoughts and notes without leaving the command line
- pkgver = 2.7.r11.gdc776b1
- pkgrel = 4
+ pkgver = v2.8.beta.r1.g7bacf4a
+ pkgrel = 1
url = https://jrnl.sh/
arch = any
license = GPL3
checkdepends = python-behave
+ checkdepends = python-pytest
+ checkdepends = python-black
makedepends = git
makedepends = python-dephell
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 15541492b28a..c034e8d3d9c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=jrnl-git
_gitname=jrnl
-pkgver=2.7.r11.gdc776b1
-pkgrel=4
+pkgver=v2.8.beta.r1.g7bacf4a
+pkgrel=1
pkgdesc="Collect your thoughts and notes without leaving the command line"
arch=('any')
url="https://jrnl.sh/"
license=('GPL3')
depends=('python')
-checkdepends=('python-behave')
+checkdepends=('python-behave' 'python-pytest' 'python-black')
makedepends=('git' 'python-dephell' 'python-setuptools')
conflicts=("jrnl")
source=("git+https://github.com/jrnl-org/jrnl.git")
@@ -22,12 +22,14 @@ pkgver() {
check() {
cd "$_gitname"
- behave
+ pytest
+ behave --no-skipped --format progress
}
prepare() {
cd "$_gitname"
dephell deps convert --from pyproject.toml --to setup.py --envs main
+ black . --check --diff | patch
}
build() {