summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2021-11-29 19:32:10 -0500
committereshrh2021-11-29 19:32:10 -0500
commit109d41c1c9bea363dc65605178024b168ab55107 (patch)
treeda98b5f3cb76bbc3a4f1f1cc7a85b210421dc8ee
parentdd54f98c2942e6edcec621e2ffdd16428ab3288b (diff)
downloadaur-109d41c1c9bea363dc65605178024b168ab55107.tar.gz
2.8.4 beta and poetry check
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c6d36c4fd94..ffc2a7da3f54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = jrnl-git
pkgdesc = Collect your thoughts and notes without leaving the command line
- pkgver = v2.8.2.r1.gb23c831d
+ pkgver = v2.8.4.beta.r11.gba8a59b2
pkgrel = 1
url = https://jrnl.sh/
arch = any
license = GPL3
- checkdepends = python-behave
- checkdepends = python-pytest
- checkdepends = python-black
+ checkdepends = python-poetry
makedepends = git
makedepends = python-dephell
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index d73e88be2467..e3fbd4850057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=jrnl-git
_gitname=jrnl
-pkgver=v2.8.2.r1.gb23c831d
+pkgver=v2.8.4.beta.r11.gba8a59b2
pkgrel=1
pkgdesc="Collect your thoughts and notes without leaving the command line"
arch=('any')
url="https://jrnl.sh/"
license=('GPL3')
depends=('python' 'python-ansiwrap' 'python-asteval' 'python-colorama' 'python-cryptography' 'python-keyring' 'python-parsedatetime' 'python-dateutil' 'python-pyxdg' 'python-pyaml')
-checkdepends=('python-behave' 'python-pytest' 'python-black')
+checkdepends=('python-poetry')
makedepends=('git' 'python-dephell' 'python-setuptools')
conflicts=("jrnl")
source=("git+https://github.com/jrnl-org/jrnl.git")
@@ -22,10 +22,11 @@ pkgver() {
check() {
cd "$_gitname"
- behave --no-skipped --format progress
-
- black setup.py --diff | patch
- black --check --diff .
+ poetry run pip install --upgrade pip
+ poetry install
+ poetry run pytest
+ poetry run black .
+ poetry env remove python
}
prepare() {