summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshrh2021-06-07 15:16:31 -0400
committereshrh2021-06-07 15:16:31 -0400
commit5f71be6c4a3ab24c464bf41d5353cc041c58a1b7 (patch)
tree7046686c6bc6489c2a2bb3c0cc60cc98e3af7e1f
parenta74c536992eb90c06cec96284d8471d2c2c3fea9 (diff)
downloadaur-5f71be6c4a3ab24c464bf41d5353cc041c58a1b7.tar.gz
add deps
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b89be32eb9c..eb52a352559c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jrnl-git
pkgdesc = Collect your thoughts and notes without leaving the command line
- pkgver = v2.8.beta.r1.g7bacf4a
- pkgrel = 3
+ pkgver = v2.8.1.r12.g5e87ff1
+ pkgrel = 2
url = https://jrnl.sh/
arch = any
license = GPL3
@@ -12,9 +12,17 @@ pkgbase = jrnl-git
makedepends = python-dephell
makedepends = python-setuptools
depends = python
+ depends = python-ansiwrap
+ depends = python-asteval
+ depends = python-colorama
+ depends = python-cryptography
+ depends = python-keyring
+ depends = python-parsedatetime
+ depends = python-dateutil
+ depends = python-pyxdg
+ depends = python-pyaml
conflicts = jrnl
source = git+https://github.com/jrnl-org/jrnl.git
md5sums = SKIP
pkgname = jrnl-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 06789123e03d..166daf9e7216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=jrnl-git
_gitname=jrnl
-pkgver=v2.8.beta.r1.g7bacf4a
-pkgrel=3
+pkgver=v2.8.1.r12.g5e87ff1
+pkgrel=2
pkgdesc="Collect your thoughts and notes without leaving the command line"
arch=('any')
url="https://jrnl.sh/"
license=('GPL3')
-depends=('python')
+depends=('python' 'python-ansiwrap' 'python-asteval' 'python-colorama' 'python-cryptography' 'python-keyring' 'python-parsedatetime' 'python-dateutil' 'python-pyxdg' 'python-pyaml')
checkdepends=('python-behave' 'python-pytest' 'python-black')
makedepends=('git' 'python-dephell' 'python-setuptools')
conflicts=("jrnl")
@@ -22,14 +22,16 @@ pkgver() {
check() {
cd "$_gitname"
- pytest
+ pytest .
behave --no-skipped --format progress
+
+ black setup.py --diff | patch
+ black --check --diff .
}
prepare() {
cd "$_gitname"
dephell deps convert --from pyproject.toml --to setup.py --envs main
- black setup.py --diff | patch
}
build() {