summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Frilling2015-08-13 22:04:01 +0200
committerTobias Frilling2015-08-13 22:04:01 +0200
commita44e092d5a2e7f0a4f2ee2db065bfb5cb68bfdff (patch)
tree4bd4f52858eb828e77fa4a889c74186bc7333c46
downloadaur-a44e092d5a2e7f0a4f2ee2db065bfb5cb68bfdff.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..428add5e23e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = jrnl-git
+ pkgdesc = A simple command line journal application that stores your journal in a plain text file
+ pkgver = 1.9.7.r16.g15ef974
+ pkgrel = 1
+ url = http://maebert.github.io/jrnl/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ conflicts = jrnl
+ options = !emptydirs
+ source = jrnl::git+https://github.com/maebert/jrnl.git
+ md5sums = SKIP
+
+pkgname = jrnl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9438c294a159
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tobias Frilling <tobias@frilling-online.de>
+pkgname=jrnl-git
+pkgver=1.9.7.r16.g15ef974
+pkgrel=1
+pkgdesc="A simple command line journal application that stores your journal in a plain text file"
+arch=('any')
+url="http://maebert.github.io/jrnl/"
+license=('MIT')
+depends=('python')
+makedepends=('git')
+conflicts=("${pkgname%-git}")
+options=(!emptydirs)
+source=("${pkgname%-git}::git+https://github.com/maebert/jrnl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}