summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsudokode2016-04-03 22:18:20 -0400
committersudokode2016-04-03 22:18:20 -0400
commit21568f98cd5da3176defced8ced93900c0a0b380 (patch)
treebc9b6bcef4605917e003e19619d361c9e062df5f
downloadaur-21568f98cd5da3176defced8ced93900c0a0b380.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..010847bfc026
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Apr 4 02:11:26 UTC 2016
+pkgbase = jshlint
+ pkgdesc = Use Douglas Crockford's jslint in a console
+ pkgver = r7.d6f914c
+ pkgrel = 1
+ url = https://github.com/sudokode/jshlint.git
+ arch = any
+ license = custom:JSON
+ makedepends = git
+ depends = js
+ source = jshlint::git+https://github.com/sudokode/jshlint.git
+ source = jslint::git+https://github.com/douglascrockford/JSLint.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = jshlint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d5c4c6e66f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: sudokode <sudokode@gmail.com>
+
+pkgname=jshlint
+pkgver=r7.d6f914c
+pkgrel=1
+pkgdesc="Use Douglas Crockford's jslint in a console"
+arch=('any')
+url="https://github.com/sudokode/jshlint.git"
+license=('custom:JSON')
+makedepends=('git')
+depends=('js')
+source=("$pkgname::git+https://github.com/sudokode/jshlint.git"
+ 'jslint::git+https://github.com/douglascrockford/JSLint.git')
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd $pkgname
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+
+ install -Dm755 jshlint "$pkgdir/usr/bin/jshlint"
+
+ install -Dm644 lint.js "$pkgdir/usr/lib/jshlint/lint.js"
+ install -Dm644 ../jslint/jslint.js "$pkgdir/usr/lib/jshlint/jslint.js"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/jshlint/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: