summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Conseil2015-06-13 00:17:50 +0200
committerSimon Conseil2015-06-13 00:17:50 +0200
commitd427928cd4b0eca3cda4af2c7784ee226b53333c (patch)
tree72321a5486151d503806ea7f01bf8a11745ac026
downloadaur-d427928cd4b0eca3cda4af2c7784ee226b53333c.tar.gz
Initial import
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
3 files changed, 48 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..5bc3d807bdd2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = jslint
+ pkgdesc = Command-line JSLint, installed through npm
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/reid/node-jslint
+ arch = any
+ license = custom:BSD and modified MIT
+ depends = nodejs
+ source = https://github.com/reid/node-jslint/archive/v0.6.1.tar.gz
+
+pkgname = jslint
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d48b8172fa87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = jslint
+ pkgdesc = Command-line JSLint, installed through npm
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/reid/node-jslint
+ arch = any
+ license = custom:BSD and modified MIT
+ depends = nodejs
+ source = https://github.com/reid/node-jslint/archive/v0.6.1.tar.gz
+ sha256sums = b1e9fc4f9e17e954c45c2fcae729691e64df1367c322f3451af9cd204f3354c5
+
+pkgname = jslint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d853238c7e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Simon Conseil <contact+aur at saimon dot org>
+# Contributor: Michael Louis Thaler <michael.louis.thaler@gmail.com>
+# Contributor: Mark Harviston infinull@gmail.com
+# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+pkgname=jslint
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Command-line JSLint, installed through npm"
+arch=('any')
+url="https://github.com/reid/node-jslint"
+license=('custom:BSD and modified MIT')
+depends=('nodejs')
+source=("https://github.com/reid/node-jslint/archive/v$pkgver.tar.gz")
+sha256sums=("b1e9fc4f9e17e954c45c2fcae729691e64df1367c322f3451af9cd204f3354c5")
+
+package() {
+ cd "$srcdir/node-$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr
+ npm install --user root -g --prefix="$pkgdir/usr"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: