summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Fonseca2018-07-14 15:39:16 -0400
committerIvan Fonseca2018-07-14 15:39:16 -0400
commite5e94c190be51d4edab3632dc68ea24521888a7d (patch)
tree96eb8dec46b57ad9aeda3e3285f8bc80ed3358c1
parent15c3a2b3aaf0fe8a770142cf071886f840fdb515 (diff)
downloadaur-e5e94c190be51d4edab3632dc68ea24521888a7d.tar.gz
0.12.0 and updated PKGBUILD format
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
4 files changed, 20 insertions, 31 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 5bc3d807bdd2..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,12 +0,0 @@
-pkgbase = jslint
- pkgdesc = Command-line JSLint, installed through npm
- pkgver = 0.6.1
- pkgrel = 1
- url = https://github.com/reid/node-jslint
- arch = any
- license = custom:BSD and modified MIT
- depends = nodejs
- source = https://github.com/reid/node-jslint/archive/v0.6.1.tar.gz
-
-pkgname = jslint
-
diff --git a/.SRCINFO b/.SRCINFO
index 4dc9c46dd8cc..7ebd2933153b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Oct 22 22:43:27 UTC 2016
pkgbase = jslint
- pkgdesc = Command-line JSLint, installed through npm
- pkgver = 0.10.3
+ pkgdesc = Easily use JSLint from the command line.
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/reid/node-jslint
arch = any
license = custom:BSD and modified MIT
makedepends = npm
depends = nodejs
- options = !emptydirs
- source = https://github.com/reid/node-jslint/archive/v0.10.3.tar.gz
- sha256sums = eda186ebf588785fbc0d34bdc6e7eb4eb2df319862866704764f449a60dd8ee8
+ source = https://registry.npmjs.org/jslint/-/jslint-0.12.0.tgz
+ sha256sums = 095a92eb05af593d00e7a07012b42a49f4b5a202e1f0bec3d3c91a5712cac983
pkgname = jslint
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82e57802ce40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.*
+*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index 00331bc4f32f..6fcb50f5c10b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: Simon Conseil <contact+aur at saimon dot org>
+# Maintainer: Ivan Fonseca <ivanfon@riseup.net>
+# Contributor: Simon Conseil <contact+aur at saimon dot org>
# Contributor: Michael Louis Thaler <michael.louis.thaler@gmail.com>
# Contributor: Mark Harviston infinull@gmail.com
# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+
pkgname=jslint
-pkgver=0.10.3
+pkgver=0.12.0
pkgrel=1
-pkgdesc="Command-line JSLint, installed through npm"
+pkgdesc="Easily use JSLint from the command line."
arch=('any')
url="https://github.com/reid/node-jslint"
license=('custom:BSD and modified MIT')
depends=('nodejs')
makedepends=('npm')
-options=(!emptydirs)
-source=("https://github.com/reid/node-jslint/archive/v$pkgver.tar.gz")
-sha256sums=("eda186ebf588785fbc0d34bdc6e7eb4eb2df319862866704764f449a60dd8ee8")
+source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+sha256sums=('095a92eb05af593d00e7a07012b42a49f4b5a202e1f0bec3d3c91a5712cac983')
package() {
- cd "$srcdir/node-$pkgname-$pkgver"
- mkdir -p $pkgdir/usr
- npm install --user root -g --prefix="$pkgdir/usr"
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${pkgdir}||" -i {} \;
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${srcdir}||" -i {} \;
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
+
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+find "${pkgdir}"/usr -type d -exec chmod 755 {} +
}
# vim:set ts=2 sw=2 et: