summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChronosX882020-03-21 01:08:35 +0400
committerChronosX882020-03-21 01:08:35 +0400
commitfbc3d3a7e9513cd0dbe3663ed96c6d8d37f20249 (patch)
tree5ed5e44ddfa513d8de4657ed1b028b34ee7576b9
downloadaur-fbc3d3a7e9513cd0dbe3663ed96c6d8d37f20249.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a803b4bf9936
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = json-glib-git
+ pkgdesc = JSON library built on GLib
+ pkgver = r1155.b4ede88
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/JsonGlib
+ arch = x86_64
+ license = GPL
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = gtk-doc
+ makedepends = meson
+ depends = glib2
+ provides = json-glib
+ conflicts = json-glib
+ source = git+https://gitlab.gnome.org/GNOME/json-glib.git
+ sha256sums = SKIP
+
+pkgname = json-glib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d196ce49387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=json-glib-git
+pkgver=r1155.b4ede88
+pkgrel=1
+pkgdesc="JSON library built on GLib"
+url="https://wiki.gnome.org/Projects/JsonGlib"
+arch=(x86_64)
+license=(GPL)
+depends=(glib2)
+conflicts=('json-glib')
+provides=('json-glib')
+makedepends=(gobject-introspection git gtk-doc meson)
+source=("git+https://gitlab.gnome.org/GNOME/json-glib.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+}
+
+build() {
+ meson ${pkgname%-git} build -D docs=true -D man=true
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+