summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPřemysl Eric Janouch2020-10-12 15:29:04 +0200
committerPřemysl Eric Janouch2020-10-12 15:29:04 +0200
commit49d10d6c08673f39650bc883e45ef729c3873fe1 (patch)
treef3115a269306d09c2adbf24b5655e836ca5d89a9
parentc83100bf0607ea8921b7474d759a39957a394d4a (diff)
downloadaur-49d10d6c08673f39650bc883e45ef729c3873fe1.tar.gz
Install license properly, change header
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00267e8b66e1..12215eacb053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = json-rpc-shell-git
pkgdesc = Shell for JSON-RPC 2.0 HTTP queries
pkgver = v1.0.0.r10.gee79249
- pkgrel = 1
+ pkgrel = 2
url = https://git.janouch.name/p/json-rpc-shell
arch = i686
arch = x86_64
- license = BSD
+ license = custom:0BSD
makedepends = cmake
makedepends = pkg-config
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 797398299b85..0093ad54ccd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Přemysl Janouch <p.janouch@gmail.com>
+# Maintainer: Přemysl Eric Janouch <p@janouch.name>
pkgname=json-rpc-shell-git
_pkgname=json-rpc-shell
pkgver=v1.0.0.r10.gee79249
-pkgrel=1
+pkgrel=2
pkgdesc="Shell for JSON-RPC 2.0 HTTP queries"
url="https://git.janouch.name/p/json-rpc-shell"
arch=('i686' 'x86_64')
-license=('BSD')
+license=('custom:0BSD')
options=(zipman)
conflicts=('json-rpc-shell')
provides=('json-rpc-shell')
@@ -40,4 +40,6 @@ build() {
package() {
cd "$srcdir/$_pkgname-build"
make install DESTDIR=$pkgdir
+ install -Dm644 "$srcdir/$_pkgname/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}