summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-14 15:38:58 +0100
committerCarl Smedstad2024-01-14 15:38:58 +0100
commit2730537afb46fa6bf4cbe24942a240cf04e5eee3 (patch)
tree16fb83767ddbb57e7b41c2513736002c74ea6b86
parent886db6689f5b09af4795c1e90a53b0a29120ce2b (diff)
downloadaur-2730537afb46fa6bf4cbe24942a240cf04e5eee3.tar.gz
upgpkg: json-schema-for-humans 0.47-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc8c2b3dcdd3..56452f2cf8ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = json-schema-for-humans
pkgdesc = Quickly generate HTML documentation from a JSON schema
- pkgver = 0.46
+ pkgver = 0.47
pkgrel = 1
url = https://github.com/coveooss/json-schema-for-humans
arch = any
license = Apache
- checkdepends = python-pytest
checkdepends = python-beautifulsoup4
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
makedepends = python-poetry
@@ -22,7 +22,7 @@ pkgbase = json-schema-for-humans
depends = python-pytz
depends = python-requests
depends = python-yaml
- source = json-schema-for-humans-0.46.tar.gz::https://github.com/coveooss/json-schema-for-humans/archive/refs/tags/v0.46.tar.gz
- sha256sums = ccfa59a733469b1a5fc4b35c5cfe1c1cb8d8ceb608b7f1c774ebfc0b2eddd4e1
+ source = json-schema-for-humans-0.47.tar.gz::https://github.com/coveooss/json-schema-for-humans/archive/refs/tags/v0.47.tar.gz
+ sha256sums = 15508f174fc10c6febc5f762f4631aea869040aef5f8d3538a7f087d4b487e08
pkgname = json-schema-for-humans
diff --git a/.gitignore b/.gitignore
index a121575aeed2..f71c635dafda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.gitignore
!PKGBUILD
!.SRCINFO
-!include-templates.patch
diff --git a/PKGBUILD b/PKGBUILD
index 99aec9cc597c..3c914b466a04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
pkgname=json-schema-for-humans
-pkgver=0.46
+pkgver=0.47
pkgrel=1
pkgdesc="Quickly generate HTML documentation from a JSON schema"
arch=(any)
@@ -27,12 +27,12 @@ makedepends=(
python-wheel
)
checkdepends=(
- python-pytest
python-beautifulsoup4
+ python-pytest
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('ccfa59a733469b1a5fc4b35c5cfe1c1cb8d8ceb608b7f1c774ebfc0b2eddd4e1')
+sha256sums=('15508f174fc10c6febc5f762f4631aea869040aef5f8d3538a7f087d4b487e08')
_archive="$pkgname-$pkgver"
@@ -45,7 +45,7 @@ build() {
check() {
cd "$_archive"
- python -m pytest
+ pytest
}
package() {