summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorentin Girard2022-01-09 22:25:29 +0100
committerCorentin Girard2022-01-09 22:25:29 +0100
commit6d27f22c6b342ef576407bbb92d443eed3036e83 (patch)
tree42269c7b53cc3c9d94e08bd6a3f11ada3c686095
downloadaur-6d27f22c6b342ef576407bbb92d443eed3036e83.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD19
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fd19582747c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = json-tui-bin
+ pkgdesc = A JSON terminal UI made in C++
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/ArthurSonzogni/json-tui
+ arch = x86_64
+ license = MIT
+ provides = json-tui
+ conflicts = json-tui
+ source = https://github.com/ArthurSonzogni/json-tui/releases/download/v1.0.3/json-tui-1.0.3-Linux.tar.gz
+ sha256sums = 6d8eacf5d23539d8bbe7b890f26ff58aafdba0ce0e06d5252dff642faf32a6ad
+
+pkgname = json-tui-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dccc7769c72
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b43f6f814b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: drarig29 <corentingirard.dev@gmail.com>
+
+pkgname=json-tui-bin
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A JSON terminal UI made in C++"
+arch=("x86_64")
+url="https://github.com/ArthurSonzogni/json-tui"
+license=("MIT")
+provides=("json-tui")
+conflicts=("json-tui")
+source=("https://github.com/ArthurSonzogni/json-tui/releases/download/v${pkgver}/json-tui-${pkgver}-Linux.tar.gz")
+sha256sums=('6d8eacf5d23539d8bbe7b890f26ff58aafdba0ce0e06d5252dff642faf32a6ad')
+
+package() {
+ install -Dm755 json-tui-${pkgver}-Linux/bin/json-tui -t "$pkgdir/usr/bin"
+}
+
+# vim: ts=2 sw=2 et: