summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-07 07:01:13 +1200
committercaltlgin2020-06-07 07:01:13 +1200
commit9ed64dc59aaec59d222f9a29774a29564373c5ba (patch)
tree04ba5d2ee08f0686882b4c2830301fa6124e455b
parent4449c11468553c54cafdd0b34bf8e3041c48e8b1 (diff)
downloadaur-9ed64dc59aaec59d222f9a29774a29564373c5ba.tar.gz
Cosmetic changes
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8bb3c37eb43..f34fa6213647 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = json2tsv
depends = glibc
provides = json2tsv
conflicts = json2tsv
+ conflicts = json2tsv-git
source = https://codemadness.org/releases/json2tsv/json2tsv-0.5.tar.gz
sha256sums = 0e919ff3ecd4eed8d1209e1da0bb6d4c4099b276168a941b8bceecfe128e1fc5
diff --git a/PKGBUILD b/PKGBUILD
index 67cb47427e45..99186cd11e94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,22 @@ pkgver=0.5
pkgrel=1
pkgdesc="JSON to TSV converter"
arch=('x86_64')
-url="https://codemadness.org/json2tsv.html"
+url="https://codemadness.org/${pkgname}.html"
license=('custom:ISC license')
-source=("https://codemadness.org/releases/json2tsv/json2tsv-${pkgver}.tar.gz")
+source=("https://codemadness.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz")
depends=('glibc')
makedepends=('gcc-libs')
-provides=('json2tsv')
-conflicts=('json2tsv')
+provides=("${pkgname}")
+conflicts=("${pkgname}" "${pkgname}-git")
sha256sums=('0e919ff3ecd4eed8d1209e1da0bb6d4c4099b276168a941b8bceecfe128e1fc5')
build() {
- cd "json2tsv-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "json2tsv-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" PREFIX="/usr" MANPREFIX="/usr/share/man" install
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file