summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-12-10 13:43:25 -0500
committerGuillaume Horel2022-12-10 13:43:25 -0500
commit922482129cef8211a15b15bd612590aa8a4928b1 (patch)
treef6b759f1d5e51a8fa8d222357c88ce2de7a15193
downloadaur-922482129cef8211a15b15bd612590aa8a4928b1.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..863946a4d47f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = jsoncpp-cmake
+ pkgdesc = C++ library for interacting with JSON; cmake version: FS#60285
+ pkgver = 1.9.5
+ pkgrel = 1
+ url = https://github.com/open-source-parsers/jsoncpp
+ arch = x86_64
+ license = MIT
+ license = custom
+ makedepends = git
+ makedepends = meson
+ makedepends = python
+ depends = gcc-libs
+ provides = jsoncpp
+ provides = libjsoncpp.so
+ conflicts = jsoncpp
+ options = staticlibs
+ source = https://github.com/open-source-parsers/jsoncpp/archive/1.9.5/jsoncpp-1.9.5.tar.gz
+ sha256sums = f409856e5920c18d0c2fb85276e24ee607d2a09b5e7d5f0a371368903c275da2
+
+pkgname = jsoncpp-cmake
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2866d8081e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Upstream Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=jsoncpp-cmake
+pkgname_=jsoncpp
+pkgver=1.9.5
+pkgrel=1
+pkgdesc="C++ library for interacting with JSON; cmake version: FS#60285"
+arch=('x86_64')
+url="https://github.com/open-source-parsers/jsoncpp"
+license=('MIT' 'custom')
+depends=('gcc-libs')
+makedepends=('git' 'meson' 'python')
+provides=('jsoncpp' 'libjsoncpp.so')
+conflicts=('jsoncpp')
+options=('staticlibs')
+source=("https://github.com/open-source-parsers/${pkgname_}/archive/${pkgver}/${pkgname_}-${pkgver}.tar.gz")
+sha256sums=('f409856e5920c18d0c2fb85276e24ee607d2a09b5e7d5f0a371368903c275da2')
+
+
+build() {
+ cmake -B build -S "${pkgname_}-${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_SBINDIR="bin" \
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+ cmake --build build
+}
+
+check() {
+ cd build
+ ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 "${pkgname_}-${pkgver}/LICENSE" -t "$pkgdir/usr/share/licenses/jsoncpp"
+}