summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2022-06-23 00:34:37 +0200
committerMatthias Lisin2022-06-23 00:34:37 +0200
commit51ccece601e4ca48815104235dc2cf0eea3af338 (patch)
tree30fd8f33033a2b97a4e5b372a042e831dba895fa
parent4b4de952bde39df68290e8093cf008ec4fe5f470 (diff)
downloadaur-jsonnet-bundler.tar.gz
upgpkg: jsonnet-bundler 0.5.1-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24faf32d0483..5b5a917a7749 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = jsonnet-bundler
pkgdesc = jsonnet package manager
- pkgver = 0.4.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://github.com/jsonnet-bundler/jsonnet-bundler
arch = x86_64
license = Apache
makedepends = go
depends = glibc
- source = https://github.com/jsonnet-bundler/jsonnet-bundler/archive/v0.4.0/jsonnet-bundler-0.4.0.tar.gz
- sha256sums = bedb42ccacf7922fec47cffc95a1e1999400fd1e6f89d817d9d75b21a60f68e7
+ source = https://github.com/jsonnet-bundler/jsonnet-bundler/archive/v0.5.1/jsonnet-bundler-0.5.1.tar.gz
+ sha256sums = 059ff88a4b8617bd8a6802a337ec6aaffd4aece10f74e53f1f3ce0b4588ac4c4
pkgname = jsonnet-bundler
diff --git a/PKGBUILD b/PKGBUILD
index a196633a71d8..33c0ba5f4b78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ml <>
pkgname=jsonnet-bundler
-pkgver=0.4.0
+pkgver=0.5.1
pkgrel=1
pkgdesc='jsonnet package manager'
arch=('x86_64')
@@ -9,7 +9,7 @@ license=('Apache')
depends=('glibc')
makedepends=('go')
source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('bedb42ccacf7922fec47cffc95a1e1999400fd1e6f89d817d9d75b21a60f68e7')
+sha256sums=('059ff88a4b8617bd8a6802a337ec6aaffd4aece10f74e53f1f3ce0b4588ac4c4')
build() {
cd "$pkgname-$pkgver"
@@ -18,7 +18,7 @@ build() {
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw'
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=vendor'
go build -ldflags "-linkmode=external -X=main.Version=v$pkgver" ./cmd/jb
}