summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlain2020-06-16 07:59:07 -0700
committerlain2020-06-16 08:08:28 -0700
commit34935985c64cc269a9dd62ee2657d6c77bb94872 (patch)
tree3934d5066f1e03eb34c53ae522ae847ac15771fe
downloadaur-34935985c64cc269a9dd62ee2657d6c77bb94872.tar.gz
First post.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD56
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34b6edb99939
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = jtaghal-git
+ pkgdesc = JTAG Hardware Abstraction Library
+ pkgver = r42.c76f8fe
+ pkgrel = 1
+ url = https://github.com/azonenberg/jtaghal-cmake.git
+ arch = i686
+ arch = x86_64
+ arch = arm
+ license = BSD-3-Clause
+ makedepends = git
+ makedepends = cmake
+ depends = protobuf
+ depends = libedit
+ optdepends = libusb
+ optdepends = libftd2xx
+ provides = jtaghal
+ conflicts = jtaghal
+ conflicts = jtaghal-git
+ source = git+https://github.com/azonenberg/jtaghal-cmake.git
+ md5sums = SKIP
+
+pkgname = jtaghal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f57e0d645aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: lain <aur@hacktheinter.net>
+pkgname=jtaghal-git
+pkgver=r42.c76f8fe
+pkgrel=1
+pkgdesc="JTAG Hardware Abstraction Library"
+provides=("${pkgname%-git}")
+conflicts=(
+ "${pkgname%-git}"
+ "${pkgname}"
+)
+arch=('i686' 'x86_64' 'arm')
+url='https://github.com/azonenberg/jtaghal-cmake.git'
+md5sums=('SKIP')
+license=('BSD-3-Clause')
+depends=(
+ 'protobuf'
+ 'libedit'
+)
+optdepends=(
+ 'libusb'
+ 'libftd2xx'
+)
+makedepends=('git' 'cmake')
+source=(
+ 'git+https://github.com/azonenberg/jtaghal-cmake.git'
+)
+
+pkgver() {
+ cd jtaghal-cmake
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd jtaghal-cmake
+ git submodule update --init --recursive
+ sed -i 's/^#include <ftd2xx\/ftd2xx.h>$/#include <ftd2xx.h>/g' \
+ lib/jtaghal/FTDIDriver.cpp \
+ lib/jtaghal/FTDIJtagInterface.cpp \
+ lib/jtaghal/FTDISWDInterface.cpp
+ sed -i '/^#include <editline\/history.h>$/d' \
+ src/jtaghal-apps/jtagsh/jtagsh.h
+}
+
+build() {
+ cd jtaghal-cmake
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "jtaghal-cmake/build"
+ make DESTDIR="$pkgdir/" install
+}