summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreidheim2018-08-08 13:09:15 +0200
committereidheim2018-08-08 13:09:15 +0200
commit0f1677ac99b3fccd93cf089569786fb060f0a608 (patch)
treed3ca9b2161852b6005f3d492419a01e26e4b0f34
parent92c173cbf039fbe4000bfe91e15c9eb3378b7dc4 (diff)
downloadaur-0f1677ac99b3fccd93cf089569786fb060f0a608.tar.gz
Bumped to 1.4.5, and updated uris since juCi++ has moved to GitLab.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18c56ff023ba..384bc13ec8e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sun Jun 10 13:48:05 UTC 2018
pkgbase = jucipp
pkgdesc = A lightweight cross-platform C++ IDE
- pkgver = 1.4.4
+ pkgver = 1.4.5
pkgrel = 1
- url = https://github.com/cppit/jucipp
+ url = https://gitlab.com/cppit/jucipp
arch = x86_64
license = MIT
makedepends = git
@@ -13,14 +11,14 @@ pkgbase = jucipp
makedepends = boost
depends = gtksourceviewmm
depends = clang
- depends = aspell
+ depends = aspell-en
depends = lldb
depends = boost-libs
depends = libgit2
depends = ctags
- source = jucipp::git+https://github.com/cppit/jucipp.git#tag=v1.4.4
- source = git+https://github.com/cppit/libclangmm.git
- source = git+https://github.com/eidheim/tiny-process-library
+ source = jucipp::git+https://gitlab.com/cppit/jucipp.git#tag=v1.4.5
+ source = git+https://gitlab.com/cppit/libclangmm.git
+ source = git+https://gitlab.com/eidheim/tiny-process-library
sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0d3677ab4927..1681c63d25d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
# Maintainer: fusion809 <CONTACT via comments at https://aur.archlinux.org/packages/jucipp>
+# Maintainer: eidheim
# Contributor: archshift
pkgname=jucipp
-ghub="https://github.com"
-cpp="$ghub/cppit"
+glab="https://gitlab.com"
+cpp="$glab/cppit"
pkgdesc='A lightweight cross-platform C++ IDE'
-pkgver=1.4.4
+pkgver=1.4.5
pkgrel=1
arch=('x86_64')
url="$cpp/jucipp"
license=('MIT')
-depends=('gtksourceviewmm' 'clang' 'aspell' 'lldb' 'boost-libs' 'libgit2' 'ctags')
+depends=('gtksourceviewmm' 'clang' 'aspell-en' 'lldb' 'boost-libs' 'libgit2' 'ctags')
makedepends=('git' 'cmake' 'pkg-config' 'boost')
source=("$pkgname::git+$url.git#tag=v${pkgver}"
"git+$cpp/libclangmm.git"
- "git+$ghub/eidheim/tiny-process-library")
+ "git+$glab/eidheim/tiny-process-library")
sha1sums=('SKIP'
'SKIP'
'SKIP')
@@ -29,8 +30,8 @@ prepare() {
cd "$srcdir/$pkgname"
git submodule init
- git config submodule.libclangmm.url "$srcdir/libclangmm"
- git config submodule.tiny-process-library.url "$srcdir/tiny-process-library"
+ git config submodule.libclangmm.url "$srcdir/lib/libclangmm"
+ git config submodule.tiny-process-library.url "$srcdir/lib/tiny-process-library"
git submodule update
mkdir -p build