summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfusion8092016-07-15 21:18:06 +1000
committerfusion8092016-07-15 21:18:06 +1000
commit6910c81c30c359eec90d8a81c8c41b1402dff414 (patch)
tree18d7e872a6277db7ff894700933ad9faa43ccac0
downloadaur-6910c81c30c359eec90d8a81c8c41b1402dff414.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD43
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7188f583269
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Fri Jul 15 11:18:06 UTC 2016
+pkgbase = jucipp
+ pkgdesc = A lightweight cross-platform C++ IDE
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/cppit/jucipp
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = boost
+ depends = gtksourceviewmm
+ depends = clang
+ depends = aspell
+ depends = lldb
+ depends = boost-libs
+ depends = libgit2
+ depends = ctags
+ source = jucipp::git+https://github.com/cppit/jucipp.git#tag=v1.2.1
+ source = git+https://github.com/cppit/libclangmm.git
+ source = git+https://github.com/eidheim/tiny-process-library
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = jucipp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a0cdc44b3c82
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+jucipp/*
+src/*
+pkg/*
+*.pkg.tar.xz
+*.swp
+libclangmm/*
+tiny-process-library/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beb21805ddd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+# Contributor: archshift
+
+pkgname=jucipp
+pkgdesc='A lightweight cross-platform C++ IDE'
+pkgver=1.2.1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/cppit/jucipp"
+license=('MIT')
+depends=('gtksourceviewmm' 'clang' 'aspell' 'lldb' 'boost-libs' 'libgit2' 'ctags')
+makedepends=('git' 'cmake' 'pkg-config' 'boost')
+source=("$pkgname::git+https://github.com/cppit/jucipp.git#tag=v${pkgver}"
+ "git+https://github.com/cppit/libclangmm.git"
+ "git+https://github.com/eidheim/tiny-process-library")
+sha1sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --tags `git rev-list --tags --max-count=1` | sed 's/v//g'
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ git submodule init
+ git config submodule.libclangmm.url "$srcdir/libclangmm"
+ git config submodule.tiny-process-library.url "$srcdir/tiny-process-library"
+ git submodule update
+
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$pkgname/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev ..
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}