summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchshift2015-12-20 03:42:45 -0800
committerarchshift2015-12-20 03:44:48 -0800
commit9f442ef5b26d417c5cd3c391422fb77e023ed482 (patch)
tree221bc1963ac102095d2108a074328f835273fb71
parent31c510bc2886f566b4ba36d3d4a8df602ce7aec4 (diff)
downloadaur-9f442ef5b26d417c5cd3c391422fb77e023ed482.tar.gz
Delete patch that worked around upstream icon issue
Previously, icons would not be installed properly due a malformed CMake script. The issue has since been fixed upstream.
-rw-r--r--.SRCINFO6
-rw-r--r--CMakeLists.patch16
-rw-r--r--PKGBUILD8
3 files changed, 5 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa2d0ff4e5f4..7137dd679aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 20 08:23:29 UTC 2015
+# Sun Dec 20 11:44:39 UTC 2015
pkgbase = jucipp-git
pkgdesc = A lightweight platform-independent C++ IDE
- pkgver = r1134.0837f6c
+ pkgver = r1136.472e45a
pkgrel = 1
url = https://github.com/cppit/jucipp
arch = i686
@@ -18,11 +18,9 @@ pkgbase = jucipp-git
source = jucipp::git+https://github.com/cppit/jucipp.git
source = git+https://github.com/cppit/libclangmm.git
source = git+https://github.com/eidheim/tiny-process-library
- source = CMakeLists.patch
sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
- sha1sums = 64ac5afbe9a3a8b92cc3001897529834cda501a5
pkgname = jucipp-git
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index fa43ffb3e981..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1bc6e2b..57e2f81 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -9,8 +9,7 @@ project (${project_name})
-
- add_subdirectory("src")
-
--find_program(XDG_DESKTOP_MENU_EXECUTABLE xdg-desktop-menu)
--if(XDG_DESKTOP_MENU_EXECUTABLE)
-- file(MAKE_DIRECTORY "/usr/share/desktop-directories") #Workaround for https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=730621
-- install(CODE "execute_process(COMMAND ${XDG_DESKTOP_MENU_EXECUTABLE} install --novendor share/juci.desktop)")
-+if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|OpenBSD|NetBSD")
-+ install(FILES "${CMAKE_SOURCE_DIR}/share/juci.desktop"
-+ DESTINATION "${CMAKE_INSTALL_PREFIX}/share/applications")
- endif()
diff --git a/PKGBUILD b/PKGBUILD
index c600ada6d807..d4da4d178fb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgbase=jucipp
pkgbase=$_pkgbase-git
pkgname=("$_pkgbase-git")
pkgdesc='A lightweight platform-independent C++ IDE'
-pkgver=r1134.0837f6c
+pkgver=r1136.472e45a
pkgrel=1
arch=('i686' 'x86_64')
@@ -15,9 +15,8 @@ makedepends=('git' 'cmake' 'pkg-config' 'boost')
source=("$_pkgbase::git+https://github.com/cppit/jucipp.git"
"git+https://github.com/cppit/libclangmm.git"
- "git+https://github.com/eidheim/tiny-process-library"
- "CMakeLists.patch")
-sha1sums=('SKIP' 'SKIP' 'SKIP' '64ac5afbe9a3a8b92cc3001897529834cda501a5')
+ "git+https://github.com/eidheim/tiny-process-library")
+sha1sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -32,7 +31,6 @@ prepare() {
git config submodule.tiny-process-library.url "$srcdir/tiny-process-library"
git submodule update
- git apply "$srcdir/CMakeLists.patch"
mkdir -p build
}