summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2015-06-10 14:04:24 +0200
committerSteffen Weber2015-06-10 14:04:24 +0200
commit1e0b901a973f6721c0068215071568cf5435e186 (patch)
tree771546713c82fdaa4955b83fc92d8eb462632ae6
downloadaur-1e0b901a973f6721c0068215071568cf5435e186.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--juffed.install11
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56a3dc3dbe81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = juffed
+ pkgdesc = Simple tabbed text editor with syntax highlighting, based on Qt4
+ pkgver = 0.10
+ pkgrel = 2
+ url = http://juffed.com
+ install = juffed.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = qscintilla
+ depends = enca
+ conflicts = juffed-git
+ conflicts = juffed-qt5-git
+ source = http://downloads.sourceforge.net/juffed/juffed-0.10-1054.tar.bz2
+ source = juffed-build-without-error.patch::https://github.com/Mezomish/juffed/commit/054bf0c0adf19a0bf5be58cf54049379f50b9211.patch
+ source = juffed-fix-build-with-enca.patch::https://github.com/Mezomish/juffed/commit/0f724eb1463c5bb87d04ebed32ea33d2d6e460ae.patch
+ md5sums = 33ca5c94fd4aedb9925e58f8f9ba9a7c
+ md5sums = e70c3050d06d26a4f3be7d1b04140492
+ md5sums = 22957a35803d971b306d8d726d5f14fe
+
+pkgname = juffed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fccb4963f7c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
+
+pkgname=juffed
+pkgver=0.10
+pkgrel=2
+pkgdesc="Simple tabbed text editor with syntax highlighting, based on Qt4"
+arch=('i686' 'x86_64')
+url="http://juffed.com"
+license=('GPL2')
+makedepends=('cmake')
+depends=('qscintilla' 'enca')
+conflicts=('juffed-git' 'juffed-qt5-git')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-1054.tar.bz2
+ $pkgname-build-without-error.patch::https://github.com/Mezomish/juffed/commit/054bf0c0adf19a0bf5be58cf54049379f50b9211.patch
+ $pkgname-fix-build-with-enca.patch::https://github.com/Mezomish/juffed/commit/0f724eb1463c5bb87d04ebed32ea33d2d6e460ae.patch)
+md5sums=('33ca5c94fd4aedb9925e58f8f9ba9a7c'
+ 'e70c3050d06d26a4f3be7d1b04140492'
+ '22957a35803d971b306d8d726d5f14fe')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../$pkgname-build-without-error.patch
+ patch -p1 -i ../$pkgname-fix-build-with-enca.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DLIB_INSTALL_DIR=/usr/lib -DCMAKE_BUILD_TYPE=release
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
diff --git a/juffed.install b/juffed.install
new file mode 100644
index 000000000000..f9c5f846b0eb
--- /dev/null
+++ b/juffed.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}