summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-21 15:34:57 +0100
committerCarl Smedstad2024-01-21 15:38:32 +0100
commit58691fb9b211fd66fcdd11e2ce8c67eaae167131 (patch)
tree98e9c996d86d864139a5820300b20a3cc772b5d6
parentf3a5c51ce6fb89a8d69e7d98c4e02dd3d3b6395f (diff)
downloadaur-58691fb9b211fd66fcdd11e2ce8c67eaae167131.tar.gz
upgpkg: 0.12.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD86
3 files changed, 59 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c1703724167..abf9cef2442b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = jujutsu
- pkgdesc = A git-compatible DVCS
- pkgver = 0.10.0
+ pkgdesc = Git-compatible VCS that is both simple and powerful
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/martinvonz/jj
arch = x86_64
- license = Apache
- makedepends = git
- makedepends = rust
+ license = Apache-2.0
+ makedepends = cargo
depends = gcc-libs
+ depends = glibc
depends = zlib
options = !lto
- source = jujutsu::git+https://github.com/martinvonz/jj#commit=ce933507df6eb51286cb7c7e3f1aaa53e581a3ef
- b2sums = SKIP
+ source = jujutsu-0.12.0.tar.gz::https://github.com/martinvonz/jj/archive/refs/tags/v0.12.0.tar.gz
+ sha256sums = da90259cd1003d9f87af277c8b20625f3b07c3fe785fb490fe17659f2082852f
pkgname = jujutsu
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 162dcd01501d..3be79bd54d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,71 @@
-# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: George Rawlinson <grawlinson@archlinux.org>
# Contributor: Thomas <thomas at 6f dot io>
pkgname=jujutsu
-pkgver=0.10.0
+_pkgname=jj
+pkgver=0.12.0
pkgrel=1
-pkgdesc='A git-compatible DVCS'
-arch=('x86_64')
-url='https://github.com/martinvonz/jj'
-license=('Apache')
-depends=('gcc-libs' 'zlib')
-makedepends=('git' 'rust')
-options=('!lto')
-_commit='ce933507df6eb51286cb7c7e3f1aaa53e581a3ef'
-source=("$pkgname::git+$url#commit=$_commit")
-b2sums=('SKIP')
-
-pkgver() {
- cd "$pkgname"
-
- git describe --tags | sed 's/^v//'
-}
+pkgdesc="Git-compatible VCS that is both simple and powerful"
+arch=(x86_64)
+url="https://github.com/martinvonz/jj"
+license=(Apache-2.0)
+depends=(
+ gcc-libs
+ glibc
+ zlib
+)
+makedepends=(cargo)
+options=(!lto)
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('da90259cd1003d9f87af277c8b20625f3b07c3fe785fb490fe17659f2082852f')
+
+_archive="$_pkgname-$pkgver"
prepare() {
- cd "$pkgname"
+ cd "$_archive"
- # download dependencies
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}
build() {
- cd "$pkgname"
+ cd "$_archive"
- cargo build --frozen --release --all-features
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features --package jj-cli
- for shell in bash fish zsh; do
- ./target/release/jj util completion "--$shell" > "jj.$shell"
- done
+ target/release/jj util completion --bash > jj.bash
+ target/release/jj util completion --zsh > jj.zsh
+ target/release/jj util completion --fish > jj.fish
}
check() {
- cd "$pkgname"
+ cd "$_archive"
+
+ # Trick to reduce the size of the target directory during test compilation.
+ # A lot of space is still required, around 10 GB.
+ mkdir -p .cargo
+ {
+ echo '[profile.dev]'
+ echo 'split-debuginfo = "unpacked"'
+ } > .cargo/config.toml
- cargo test --frozen --all-features
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features --package jj-cli
}
package() {
- cd "$pkgname"
+ cd "$_archive"
- # binary
- install -vDm755 -t "$pkgdir/usr/bin" target/release/jj
+ install -Dm755 -t "$pkgdir/usr/bin" target/release/jj
- # documentation
- install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
- cp -vr docs "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 jj.bash "$pkgdir/usr/share/bash-completion/completions/jj"
+ install -Dm644 jj.zsh "$pkgdir/usr/share/zsh/site-functions/_jj"
+ install -Dm644 jj.fish "$pkgdir/usr/share/fish/completions/jj.fish"
- # shell completions
- install -vDm644 jj.bash "$pkgdir/usr/share/bash-completion/completions/jj"
- install -vDm644 jj.fish "$pkgdir/usr/share/fish/vendor_completions.d/jj.fish"
- install -vDm644 jj.zsh "$pkgdir/usr/share/zsh/site-functions/_jj"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" ./*.md
+ cp --archive ./docs/* "$pkgdir/usr/share/doc/$pkgname"
}