summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Ryzhikov2020-06-13 19:40:03 +0300
committerPlaton Ryzhikov2020-06-13 19:40:03 +0300
commit68295b4b1b80bb36f45b2370c1fd863ae59a5715 (patch)
tree98f4c537d2e3ded1585a01726117851a3f4ee213
parentd441d73352027c9b380743e40c5bd400c978ab2c (diff)
downloadaur-68295b4b1b80bb36f45b2370c1fd863ae59a5715.tar.gz
fix package info
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 245ace390bb6..1e94f44ed446 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -42,7 +42,7 @@ pkgbase = julia-aarch64-git
sha256sums = 856dab2da8124df95e4fbd17f1164bebe1b10e99852fedf38f9dfe31f8ae295c
sha256sums = 0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7
-pkgname = julia-git
+pkgname = julia-aarch64-git
optdepends = openblas-lapack: multithreaded replacement for lapack
optdepends = fftw: If using the FFTW package from julia
optdepends = gnuplot: If using the Gaston Package from julia
@@ -50,7 +50,7 @@ pkgname = julia-git
conflicts = julia
backup = etc/julia/startup.jl
-pkgname = julia-git-docs
+pkgname = julia-aarch64-git-docs
pkgdesc = Documentation and examples for Julia
arch = any
depends = julia
diff --git a/PKGBUILD b/PKGBUILD
index 6c9a08624338..10cd6542ed75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: Lex Black <autumn-wind at web dot de>
+# Maintainer: Platon Ryzhikov <ihummer63@yandex.ru>
+# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: Michael Jakl <jakl.michael@gmail.com>
# With contributions from many kind people at https://aur.archlinux.org/packages/julia-git/
+# Includes Make.user and compilation flags for aarch64
_pkgbase=julia
pkgbase=${_pkgbase}-aarch64-git
-pkgname=(julia-git julia-git-docs)
+pkgname=(julia-aarch64-git julia-aarch64-git-docs)
pkgver=1.6.0.DEV.r46933.g4e2fb5c72c2
pkgrel=1
arch=(aarch64)
@@ -59,7 +61,7 @@ prepare() {
build() {
# See FS#58221 for why USE_SYSTEM_ARPACK=0 is used, for now
export PATH="$srcdir/bin:$PATH"
- env CFLAGS="-O2 -pipe -fstack-protector-strong -w" CXXFLAGS="-O2 -pipe -fstack-protector-strong -w" make VERBOSE=1 -C "$_pkgbase" -j2
+ env CFLAGS="-O2 -pipe -fstack-protector-strong -w" CXXFLAGS="-O2 -pipe -fstack-protector-strong -w" make VERBOSE=1 -C "$_pkgbase"
# Building doc
cd $_pkgbase/doc
@@ -79,7 +81,7 @@ build() {
# rm -r depot/compiled
#}
-package_julia-git() {
+package_julia-aarch64-git() {
optdepends=('openblas-lapack: multithreaded replacement for lapack'
'fftw: If using the FFTW package from julia'
'gnuplot: If using the Gaston Package from julia')
@@ -104,7 +106,7 @@ package_julia-git() {
find ${pkgdir} -name ".gitignore" -delete
}
-package_julia-git-docs() {
+package_julia-aarch64-git-docs() {
arch=('any')
pkgdesc='Documentation and examples for Julia'
depends=(julia)