summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Ryzhikov2021-06-07 21:20:10 +0300
committerPlaton Ryzhikov2021-06-07 21:20:10 +0300
commit812f3e809e4ed73b175d573aac52c4430ee86c07 (patch)
treedae62890b838e037a07c73fed0f65f45cee0629f
parent5523dd22fd2c9945be973c4394e00312cb0d60d9 (diff)
downloadaur-812f3e809e4ed73b175d573aac52c4430ee86c07.tar.gz
update to v1.7
-rw-r--r--.SRCINFO21
-rw-r--r--Make.user13
-rw-r--r--PKGBUILD40
-rw-r--r--julia-system-cblas.patch133
-rw-r--r--libunwind-version.patch17
5 files changed, 27 insertions, 197 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bbd592c23fb..a796053b21b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = julia-aarch64-git
pkgdesc = High-level, high-performance, dynamic programming language
- pkgver = 1.6.0.DEV.r48221.gba06f439d18
+ pkgver = 1.7.0.DEV.r49718.ge2ad3731681
pkgrel = 1
url = https://julialang.org/
arch = aarch64
@@ -10,36 +10,32 @@ pkgbase = julia-aarch64-git
makedepends = gmp
makedepends = python
makedepends = git
- depends = cblas
+ depends = fftw
depends = hicolor-icon-theme
depends = libgit2
depends = libunwind
depends = libutf8proc
- depends = openblas
- depends = icu
depends = suitesparse
depends = mbedtls
depends = mpfr
depends = openlibm
depends = pcre2
- depends = libssh2
+ depends = llvm-libs
+ depends = llvm
depends = curl
depends = zlib
+ depends = libssh2
depends = xdg-utils
depends = desktop-file-utils
depends = gtk-update-icon-cache
depends = patchelf
- depends = llvm
+ depends = p7zip
source = git+https://github.com/JuliaLang/julia.git#branch=master
source = Make.user
- source = julia-system-cblas.patch
- source = libunwind-version.patch
source = make-install-no-build.patch
sha256sums = SKIP
- sha256sums = 66302108f04242392379677e70ba9b9eb8961e35dc87915a738137aaa67db231
- sha256sums = d4c8fe9eec1bc416549924ae328ceb3f63cc736ecd5e67886faa924e7c14bc5d
- sha256sums = 856dab2da8124df95e4fbd17f1164bebe1b10e99852fedf38f9dfe31f8ae295c
- sha256sums = 0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7
+ sha256sums = SKIP
+ sha256sums = 8be4605f92a009072ca7e843549c225fc4e959893498e7c4f8f79e861e63714d
pkgname = julia-aarch64-git
optdepends = openblas-lapack: multithreaded replacement for lapack
@@ -56,4 +52,3 @@ pkgname = julia-aarch64-git-docs
provides = julia-docs
conflicts = julia-docs
conflicts = julia-git-doc
-
diff --git a/Make.user b/Make.user
index 0ca8657cd1cd..899b808442e8 100644
--- a/Make.user
+++ b/Make.user
@@ -1,18 +1,19 @@
prefix:=/usr
sysconfdir:=/etc
-MARCH:=armv8-a
+MARCH:=native
JULIA_CPU_TARGET:=native
+USE_BINARYBUILDER:=0
USE_SYSTEM_LLVM:=1
USE_SYSTEM_LIBUNWIND:=1
USE_SYSTEM_PCRE:=1
-USE_SYSTEM_LIBM:=0
+#USE_SYSTEM_LIBM:=0
USE_SYSTEM_OPENLIBM:=1
USE_SYSTEM_DSFMT:=0
-USE_SYSTEM_BLAS:=1
-USE_SYSTEM_LAPACK:=1
+USE_SYSTEM_BLAS:=0
+USE_SYSTEM_LAPACK:=0
USE_SYSTEM_GMP:=1
USE_SYSTEM_MPFR:=1
-USE_SYSTEM_SUITESPARSE:=1
+USE_SYSTEM_SUITESPARSE:=0
USE_SYSTEM_LIBUV:=0
USE_SYSTEM_UTF8PROC:=1
USE_SYSTEM_MBEDTLS:=1
@@ -21,4 +22,4 @@ USE_SYSTEM_CURL:=1
USE_SYSTEM_LIBGIT2:=1
USE_SYSTEM_PATCHELF:=1
USE_SYSTEM_ZLIB:=1
-#USE_SYSTEM_P7ZIP:=1
+USE_SYSTEM_P7ZIP:=1
diff --git a/PKGBUILD b/PKGBUILD
index 758408b27dce..f7d7abbc21f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,25 @@
_pkgbase=julia
pkgbase=${_pkgbase}-aarch64-git
pkgname=(julia-aarch64-git julia-aarch64-git-docs)
-pkgver=1.6.0.DEV.r48221.gba06f439d18
+pkgver=1.7.0.DEV.r49718.ge2ad3731681
pkgrel=1
arch=(aarch64)
pkgdesc='High-level, high-performance, dynamic programming language'
url='https://julialang.org/'
license=(MIT)
-depends=(cblas hicolor-icon-theme libgit2 libunwind libutf8proc openblas icu
- suitesparse mbedtls mpfr openlibm pcre2 libssh2 curl zlib
- xdg-utils desktop-file-utils gtk-update-icon-cache patchelf llvm)
+# build fails with system blas/openblas
+depends=(fftw hicolor-icon-theme libgit2 libunwind libutf8proc #openblas cblas
+ suitesparse mbedtls mpfr openlibm pcre2 llvm-libs llvm
+ curl zlib libssh2 xdg-utils desktop-file-utils gtk-update-icon-cache patchelf p7zip)
makedepends=(cmake gcc-fortran gmp python git)
# Needed if building the documentation
#makedepends+=('juliadoc-git' 'texlive-langcjk' 'texlive-latexextra')
source=(git+https://github.com/JuliaLang/julia.git#branch=master
Make.user
- julia-system-cblas.patch
- libunwind-version.patch
make-install-no-build.patch)
sha256sums=('SKIP'
- '66302108f04242392379677e70ba9b9eb8961e35dc87915a738137aaa67db231'
- 'd4c8fe9eec1bc416549924ae328ceb3f63cc736ecd5e67886faa924e7c14bc5d'
- '856dab2da8124df95e4fbd17f1164bebe1b10e99852fedf38f9dfe31f8ae295c'
- '0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7')
+ 'SKIP'
+ '8be4605f92a009072ca7e843549c225fc4e959893498e7c4f8f79e861e63714d')
pkgver() {
cd $_pkgbase
@@ -47,30 +44,17 @@ prepare() {
msg2 'Configuring the build...'
cp -v $srcdir/Make.user .
- # Add and use option to build with system cblas
- patch -p1 -i ../julia-system-cblas.patch
-
- # Fixing libunwind version check
- # https://github.com/JuliaLang/julia/pull/29082
- patch -p1 -i ../libunwind-version.patch
-
- # Don't build again in install
+# Don't build again in install
patch -p1 -i ../make-install-no-build.patch
- # For some reason during build time julia tries to load
- # libgcc_s and libopenlibm from build directory instead of system ones
- mkdir usr
- mkdir usr/lib
- cp /usr/lib/libgcc_s.so.1 usr/lib
- cp /usr/lib/libopenlibm.so* usr/lib
+# Fix test failure
+ sed -e 's|0.22314355f0 + 3.1415927f0im|0.22314355f0 - 3.1415927f0im|' -i stdlib/LinearAlgebra/test/lu.jl
}
build() {
# See FS#58221 for why USE_SYSTEM_ARPACK=0 is used, for now
- export PATH="$srcdir/bin:$PATH"
- #hack to build stringreplace, otherwise install will fail
- cp "$_pkgbase"/Makefile{.orig,}
- env CFLAGS="-O2 -pipe -fstack-protector-strong -w" CXXFLAGS="-O2 -pipe -fstack-protector-strong -w" make VERBOSE=1 -C "$_pkgbase"
+ #export PATH="$srcdir/bin:$PATH"
+ env CFLAGS="-O2 -pipe -fstack-protector-strong -w" CXXFLAGS="-O2 -pipe -fstack-protector-strong -w" make VERBOSE=1 -C "$_pkgbase" -j2
# Building doc
cd $_pkgbase/doc
diff --git a/julia-system-cblas.patch b/julia-system-cblas.patch
deleted file mode 100644
index 16f91c8c5dd5..000000000000
--- a/julia-system-cblas.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-From 0c442318196389d653ee21eba65d8c4f7beb72a0 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Fri, 5 Oct 2018 15:52:17 +0000
-Subject: [PATCH] Use a dedicated cblas library, that may or may not be in fact
- the blas one.
-
-Openblas can be built with statically compiled convenience copies of
-cblas, but if not, then the system libcblas.so should be used.
----
- Make.inc | 12 +++++++++++-
- Makefile | 3 +++
- base/Makefile | 4 ++++
- stdlib/LinearAlgebra/src/blas.jl | 15 +++++++++++++--
- 4 files changed, 31 insertions(+), 3 deletions(-)
-
-diff --git a/Make.inc b/Make.inc
-index b00a41b356d8..7bc6cd69e863 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -945,6 +945,7 @@ endif
- ifeq ($(USE_SYSTEM_BLAS), 1)
- ifeq ($(OS), Darwin)
- USE_BLAS64 := 0
-+USE_SYSTEM_CBLAS := 0
- USE_SYSTEM_LAPACK := 0
- LIBBLAS := -L$(build_libdir) -lgfortblas
- LIBBLASNAME := libgfortblas
-@@ -957,12 +958,21 @@ LIBBLAS := -L$(build_shlibdir) -lopenblas
- LIBBLASNAME := libopenblas
- endif
-
--# OpenBLAS builds LAPACK as part of its build.
-+# OpenBLAS builds cblas/LAPACK as part of its build.
- # We only need to build LAPACK if we are not using OpenBLAS.
- ifeq ($(USE_SYSTEM_BLAS), 0)
-+LIBCBLAS := $(LIBBLAS)
-+LIBCBLASNAME := $(LIBBLASNAME)
- LIBLAPACK := $(LIBBLAS)
- LIBLAPACKNAME := $(LIBBLASNAME)
- else
-+ifeq ($(USE_SYSTEM_CBLAS), 1)
-+LIBCBLAS ?= -lcblas
-+LIBCBLASNAME ?= libcblas
-+else
-+LIBCBLAS := -L$(build_shlibdir) -lcblas $(LIBBLAS)
-+LIBCBLASNAME := libcblas
-+endif
- ifeq ($(USE_SYSTEM_LAPACK), 1)
- LIBLAPACK ?= -llapack
- LIBLAPACKNAME ?= liblapack
-diff --git a/Makefile b/Makefile
-index 6063e79ae956..7df60b8170d6 100644
---- a/Makefile
-+++ b/Makefile
-@@ -184,6 +184,9 @@ endif
- endif
-
- JL_PRIVATE_LIBS-$(USE_SYSTEM_BLAS) += $(LIBBLASNAME)
-+ifneq ($(LIBCBLASNAME),$(LIBBLASNAME))
-+JL_PRIVATE_LIBS-$(USE_SYSTEM_CBLAS) += $(LIBCBLASNAME)
-+endif
- ifneq ($(LIBLAPACKNAME),$(LIBBLASNAME))
- JL_PRIVATE_LIBS-$(USE_SYSTEM_LAPACK) += $(LIBLAPACKNAME)
- endif
-diff --git a/base/Makefile b/base/Makefile
-index 70e6da933d70..8ecfa6902b59 100644
---- a/base/Makefile
-+++ b/base/Makefile
-@@ -42,6 +42,7 @@ else
- endif
- @echo "const libm_name = \"$(LIBMNAME)\"" >> $@
- @echo "const libblas_name = \"$(LIBBLASNAME)\"" >> $@
-+ @echo "const libcblas_name = \"$(LIBCBLASNAME)\"" >> $@
- @echo "const liblapack_name = \"$(LIBLAPACKNAME)\"" >> $@
- ifeq ($(USE_BLAS64), 1)
- @echo "const USE_BLAS64 = true" >> $@
-@@ -183,6 +184,9 @@ endif
- $(eval $(call symlink_system_library,libpcre2-8,PCRE))
- $(eval $(call symlink_system_library,libdSFMT,DSFMT))
- $(eval $(call symlink_system_library,$(LIBBLASNAME),BLAS))
-+ifneq ($(LIBCBLASNAME),$(LIBBLASNAME))
-+$(eval $(call symlink_system_library,$(LIBCBLASNAME),CBLAS))
-+endif
- ifneq ($(LIBLAPACKNAME),$(LIBBLASNAME))
- $(eval $(call symlink_system_library,$(LIBLAPACKNAME),LAPACK))
- endif
-diff --git a/stdlib/LinearAlgebra/src/blas.jl b/stdlib/LinearAlgebra/src/blas.jl
-index fee8c9e74d7e..8c76d1acbf29 100644
---- a/stdlib/LinearAlgebra/src/blas.jl
-+++ b/stdlib/LinearAlgebra/src/blas.jl
-@@ -61,6 +61,7 @@ export
-
-
- const libblas = Base.libblas_name
-+const libcblas = Base.libcblas_name
- const liblapack = Base.liblapack_name
-
- import LinearAlgebra
-@@ -101,6 +102,16 @@ else
- end
- end
-
-+if libcblas == libblas
-+ macro cblasfunc(x)
-+ return @blasfunc(x)
-+ end
-+else
-+ macro cblasfunc(x)
-+ return Expr(:quote, x)
-+ end
-+end
-+
- openblas_get_config() = strip(unsafe_string(ccall((@blasfunc(openblas_get_config), libblas), Ptr{UInt8}, () )))
-
- """
-@@ -300,7 +311,7 @@ for (fname, elty) in ((:cblas_zdotc_sub,:ComplexF64),
- # DOUBLE PRECISION DX(*),DY(*)
- function dotc(n::Integer, DX::Union{Ptr{$elty},AbstractArray{$elty}}, incx::Integer, DY::Union{Ptr{$elty},AbstractArray{$elty}}, incy::Integer)
- result = Ref{$elty}()
-- ccall((@blasfunc($fname), libblas), Cvoid,
-+ ccall((@cblasfunc($fname), libcblas), Cvoid,
- (BlasInt, Ptr{$elty}, BlasInt, Ptr{$elty}, BlasInt, Ptr{$elty}),
- n, DX, incx, DY, incy, result)
- result[]
-@@ -318,7 +329,7 @@ for (fname, elty) in ((:cblas_zdotu_sub,:ComplexF64),
- # DOUBLE PRECISION DX(*),DY(*)
- function dotu(n::Integer, DX::Union{Ptr{$elty},AbstractArray{$elty}}, incx::Integer, DY::Union{Ptr{$elty},AbstractArray{$elty}}, incy::Integer)
- result = Ref{$elty}()
-- ccall((@blasfunc($fname), libblas), Cvoid,
-+ ccall((@cblasfunc($fname), libcblas), Cvoid,
- (BlasInt, Ptr{$elty}, BlasInt, Ptr{$elty}, BlasInt, Ptr{$elty}),
- n, DX, incx, DY, incy, result)
- result[]
diff --git a/libunwind-version.patch b/libunwind-version.patch
deleted file mode 100644
index c2abc6113f13..000000000000
--- a/libunwind-version.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/julia_internal.h b/src/julia_internal.h
-index 186b5d7b2b..33143f2062 100644
---- a/src/julia_internal.h
-+++ b/src/julia_internal.h
-@@ -612,12 +612,9 @@ extern volatile int jl_in_stackwalk;
- # include <libunwind.h>
- typedef unw_context_t bt_context_t;
- typedef unw_cursor_t bt_cursor_t;
--# if (!defined(SYSTEM_LIBUNWIND) || UNW_VERSION_MAJOR > 1 || \
-- (UNW_VERSION_MAJOR == 1 && UNW_VERSION_MINOR != 0 && UNW_VERSION_MINOR != 1))
- // Enable our memory manager only for libunwind with our patch or
- // on a newer release
- # define JL_UNW_HAS_FORMAT_IP 1
--# endif
- #else
- // Unwinding is disabled
- typedef int bt_context_t;