summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2019-01-06 17:38:36 +0000
committerJonathon Fernyhough2019-01-06 17:38:36 +0000
commit62109eb6ff3083055ca755efc94ed4871cc56fae (patch)
tree19a447a771ec9ca4409e36cab5811c2524d10a0b
parentac3485ace47b22f1df1c5d1eb4867acf68385d53 (diff)
downloadaur-62109eb6ff3083055ca755efc94ed4871cc56fae.tar.gz
Catch case where dep is single value
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 090501343562..77e6455fff36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ _deps() {
for (key, value) in alldeps
vers = split(key, \"-\")
- if version >= vers[1] && version <= vers[2]
+ if version == vers[1] || (version > vers[1] && length(vers) == 2 && version <= vers[2])
merge!(deps, value)
end
end