summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-11-07 13:30:50 +0100
committerNarrat2015-11-07 13:30:50 +0100
commit2031540024100e66597dbfd0ae0523205b883b6d (patch)
tree169deea2bbe9a8ed33b143722bc46ac42744851c
parent542383a3d552dbd9421129eacba7208b2d49617f (diff)
downloadaur-2031540024100e66597dbfd0ae0523205b883b6d.tar.gz
Julia: Import the ld.so handling from community/julia
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff4324e27d0e..4b08c97d8948 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,9 @@ prepare() {
cd $_pkgbase
git submodule init
git submodule update
+
+ # For /etc/ld.so.conf.d/
+ echo '/usr/lib/julia' > julia.conf
}
build() {
@@ -72,6 +75,7 @@ build() {
}
package_julia-git() {
+ backup=('etc/ld.so.conf.d/julia.conf' 'etc/julia/juliarc.jl')
depends=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm' 'mpfr' 'openlibm' 'openspecfun' 'pcre2' 'suitesparse' 'patchelf' 'hicolor-icon-theme' 'xdg-utils') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
optdepends=('gnuplot: If using the Gaston Package from julia')
install=julia.install
@@ -104,6 +108,9 @@ package_julia-git() {
USE_LLVM_SHLIB=0 \
install
+ # For /etc/ld.so.conf.d, FS#41731
+ install -Dm644 julia.conf "$pkgdir/etc/ld.so.conf.d/julia.conf"
+
# Remove doc files
rm -r $pkgdir/usr/share/doc/julia