summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2017-07-12 21:13:48 +0200
committerNarrat2017-07-12 21:13:48 +0200
commit836e846e5bb01ca8ebaf47cdf4d9ffa366cb1c50 (patch)
treeec4bed5567412057cd85ac6c058f82a57520a2e6
parent161324244ee1da78530e28b463c3ac5b29d6bef3 (diff)
downloadaur-836e846e5bb01ca8ebaf47cdf4d9ffa366cb1c50.tar.gz
julia: reformat depends
multiline for oversight
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c70e8d7c677..02be52bf65af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Sat Aug 13 19:24:59 UTC 2016
pkgbase = julia-git
pkgdesc = High-level, high-performance, dynamic programming language
pkgver = 0.6.0.dev.r33116.ge4b5233
diff --git a/PKGBUILD b/PKGBUILD
index 56ae1babac4e..db6f8c00acd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,10 @@ arch=('i686' 'x86_64')
url="http://julialang.org"
license=('MIT')
makedepends=('gcc-fortran' 'git')
-makedepends+=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm' 'mbedtls' 'mpfr' 'openlibm' 'openspecfun' 'pcre2' 'suitesparse' 'patchelf' 'hicolor-icon-theme' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
+makedepends+=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm'
+ 'mbedtls' 'mpfr' 'openlibm' 'openspecfun' 'pcre2'
+ 'suitesparse' 'patchelf' 'hicolor-icon-theme'
+ 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
# Needed if building the documentation
#makedepends+=('juliadoc-git' 'texlive-langcjk' 'texlive-latexextra')
options=('!emptydirs')
@@ -59,7 +62,10 @@ build() {
package_julia-git() {
backup=('etc/ld.so.conf.d/julia.conf' 'etc/julia/juliarc.jl')
- depends=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm' 'mbedtls' 'mpfr' 'openlibm' 'openspecfun' 'pcre2' 'suitesparse' 'patchelf' 'hicolor-icon-theme' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
+ depends=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm'
+ 'mbedtls' 'mpfr' 'openlibm' 'openspecfun' 'pcre2'
+ 'suitesparse' 'patchelf' 'hicolor-icon-theme'
+ 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
optdepends=('gnuplot: If using the Gaston Package from julia')
provides=('julia')
conflicts=('julia')