summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-09-10 00:35:16 +0200
committerNarrat2015-09-10 00:40:13 +0200
commit9c7e3c6d3fab003fca1ad5caf64f84a92aa932c3 (patch)
treefafea2e1b3cadf9760e06b557f30a86b5b640317
parent551d6201c4c8bce590808a07161681bc2d5932d3 (diff)
downloadaur-9c7e3c6d3fab003fca1ad5caf64f84a92aa932c3.tar.gz
Julia: Remove rev counter from pkgver
This thing is misleading with the branching system used by the julia devs. And use the correct $branch:VERSION information if another branch than master is used (like release-0.4 and co)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ad74becb9cf..a880d3590ff2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = julia-git
pkgdesc = High-level, high-performance, dynamic programming language
- pkgver = 0.4.0.dev.5710.gaf6f214
+ pkgver = 0.5.0.dev.g7cd05db
pkgrel = 1
url = http://julialang.org
arch = i686
@@ -21,7 +21,7 @@ pkgbase = julia-git
makedepends = suitesparse
makedepends = patchelf
options = !emptydirs
- source = git://github.com/JuliaLang/julia.git
+ source = git://github.com/JuliaLang/julia.git#branch=master
md5sums = SKIP
pkgname = julia-git
diff --git a/PKGBUILD b/PKGBUILD
index 61780cc60b98..269a143a64dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgbase=julia
pkgbase=${_pkgbase}-git
pkgname=('julia-git' 'julia-git-docs')
-pkgver=0.4.0.dev.5710.gaf6f214
+pkgver=0.5.0.dev.g7cd05db
pkgrel=1
pkgdesc='High-level, high-performance, dynamic programming language'
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ makedepends=('gcc-fortran' 'arpack' 'fftw' 'git' 'gmp' 'libgit2' 'libunwind' 'll
# Needed if building the documentation
#makedepends+=('python2-sphinx' 'python2-sphinx_rtd_theme' 'python-pip' 'texlive-langcjk' 'texlive-latexextra')
options=('!emptydirs')
-source=('git://github.com/JuliaLang/julia.git')
+source=(git://github.com/JuliaLang/julia.git#branch=master)
md5sums=('SKIP')
@@ -23,9 +23,9 @@ pkgver() {
cd $_pkgbase
# use the version from VERSION file
- ver=`git show master:VERSION | sed 's/-/./g'`
+ ver=`git show makepkg:VERSION | sed 's/-/./g'`
# strip the last tag name from the HEAD description
- rev=`git describe --tags | sed 's/^.\+-\([0-9]\+-g[0-9a-f]\+\)$/\1/;s/-/./g'`
+ rev=`git describe --tags | sed 's/^.\+-\(g[0-9a-f]\+\)$/\1/;s/-/./g'`
echo $ver.$rev
}