summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-09-23 15:36:54 +0100
committerJonathon Fernyhough2018-09-23 15:36:54 +0100
commit1887c25d3402a38d13f8dc0973fd2ad34279cdf9 (patch)
tree0b3e493b28ca4452b617d81897d132503a160c3b
parentea0d0fdbecbdfb0c6bac61ddf69ccf68ea9f5a76 (diff)
downloadaur-1887c25d3402a38d13f8dc0973fd2ad34279cdf9.tar.gz
Update for 1.12.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f91a01ac27f6..de4515da58f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = julia-ijulia
pkgdesc = Julia-language backend combined with the Jupyter interactive environment
- pkgver = 1.10.0
- pkgrel = 2
+ pkgver = 1.12.0
+ pkgrel = 1
url = https://github.com/JuliaLang/IJulia.jl
arch = any
license = MIT
makedepends = julia-conda
+ makedepends = julia-versionparsing
depends = julia
depends = julia-compat
depends = julia-json
@@ -13,8 +14,8 @@ pkgbase = julia-ijulia
depends = julia-softglobalscope
depends = julia-zmq
depends = jupyter
- source = julia-ijulia-1.10.0.tar.gz::https://github.com/JuliaLang/IJulia.jl/archive/v1.10.0.tar.gz
- sha256sums = 2768d2a98c8522b252dac9651863cb06eae48c1509fc9c75d490a1c2c9452f81
+ source = julia-ijulia-1.12.0.tar.gz::https://github.com/JuliaLang/IJulia.jl/archive/v1.12.0.tar.gz
+ sha256sums = 03ba7cbd482fc33905968a8aa261e49f235a5031ad165b5aa4e6d8812aed72c8
pkgname = julia-ijulia
diff --git a/PKGBUILD b/PKGBUILD
index e79fb6bd14a6..381787c69f5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=julia-ijulia
_pkgname=IJulia
-pkgver=1.10.0
-pkgrel=2
+pkgver=1.12.0
+pkgrel=1
pkgdesc='Julia-language backend combined with the Jupyter interactive environment'
arch=(any)
url=https://github.com/JuliaLang/IJulia.jl
@@ -18,10 +18,11 @@ depends=(julia
)
makedepends=(
julia-conda
+ julia-versionparsing
)
source=($pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$_pkgname.jl/archive/v$pkgver.tar.gz)
-sha256sums=('2768d2a98c8522b252dac9651863cb06eae48c1509fc9c75d490a1c2c9452f81')
+sha256sums=('03ba7cbd482fc33905968a8aa261e49f235a5031ad165b5aa4e6d8812aed72c8')
prepare() {
cd $_pkgname.jl-$pkgver/deps
@@ -40,6 +41,8 @@ build() {
# Fix reference to $srcdir
sed -i "s|$srcdir/$_pkgname.jl-$pkgver|/usr/share/julia/environments/v1.0/$_pkgname|" \
share/jupyter/kernels/julia-1.0/kernel.json
+
+ msg2 "NOTE: If the Julia kernel fails to run, clear your $HOME/.julia/cache"
}
check() {