summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2021-01-28 19:14:10 +0800
committerJingbei Li2021-01-28 19:14:10 +0800
commit28e8fdf8f2c7398785430a69bb6bcb81bf9b2800 (patch)
tree72a5129eb2c4841125b11a9f79c5bd1748a14570
parentaeb51cf89e7dead2fc244b83ed05b84e2d8e5e42 (diff)
downloadaur-28e8fdf8f2c7398785430a69bb6bcb81bf9b2800.tar.gz
upgraded to 1.5.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5781c75e5395..01ec02234675 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = julia-mkl
pkgdesc = High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)
- pkgver = 1.5.2
+ pkgver = 1.5.3
pkgrel = 1
epoch = 2
url = https://julialang.org/
@@ -11,7 +11,7 @@ pkgbase = julia-mkl
makedepends = gmp
makedepends = python
makedepends = intel-common-libs
- makedepends = llvm
+ makedepends = llvm10
depends = fftw
depends = hicolor-icon-theme
depends = intel-mkl
@@ -22,15 +22,15 @@ pkgbase = julia-mkl
depends = mbedtls
depends = openlibm
depends = pcre2
- depends = llvm-libs
+ depends = llvm10-libs
optdepends = gnuplot: If using the Gaston Package from julia
provides = julia
conflicts = julia
conflicts = julia-git
backup = etc/julia/startup.jl
- source = https://github.com/JuliaLang/julia/releases/download/v1.5.2/julia-1.5.2-full.tar.gz
+ source = https://github.com/JuliaLang/julia/releases/download/v1.5.3/julia-1.5.3-full.tar.gz
source = make-install-no-build.patch
- sha256sums = 850aed3fe39057488ec633f29af705f5ada87e3058fd65e48ad26f91b713a19a
+ sha256sums = fb69337ca037576758547c7eed9ae8f153a9c052318327b6b7f1917408c14d91
sha256sums = 0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7
pkgname = julia-mkl
diff --git a/PKGBUILD b/PKGBUILD
index d634a87cad9f..2c353b500cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,21 @@
pkgname=julia-mkl
_pkgname=julia
epoch=2
-pkgver=1.5.2
+pkgver=1.5.3
pkgrel=1
arch=(x86_64)
pkgdesc='High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)'
url='https://julialang.org/'
license=(MIT)
-depends=(fftw hicolor-icon-theme intel-mkl libgit2 libunwind libutf8proc suitesparse mbedtls openlibm pcre2 llvm-libs)
-makedepends=(cmake gcc-fortran gmp python intel-common-libs llvm)
+depends=(fftw hicolor-icon-theme intel-mkl libgit2 libunwind libutf8proc suitesparse mbedtls openlibm pcre2 llvm10-libs)
+makedepends=(cmake gcc-fortran gmp python intel-common-libs llvm10)
optdepends=('gnuplot: If using the Gaston Package from julia')
provides=('julia')
conflicts=('julia' 'julia-git')
backup=(etc/julia/startup.jl)
source=("https://github.com/JuliaLang/julia/releases/download/v$pkgver/$_pkgname-$pkgver-full.tar.gz"
make-install-no-build.patch)
-sha256sums=('850aed3fe39057488ec633f29af705f5ada87e3058fd65e48ad26f91b713a19a'
+sha256sums=('fb69337ca037576758547c7eed9ae8f153a9c052318327b6b7f1917408c14d91'
'0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7')
prepare() {