summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2021-04-21 20:12:08 +0800
committerJingbei Li2021-04-21 20:12:08 +0800
commit618c81094486c5840817614f2dc2592ed325aa40 (patch)
treef301199887ec7e0b82e5274bc9332b0a684ddfac
parent28e8fdf8f2c7398785430a69bb6bcb81bf9b2800 (diff)
downloadaur-618c81094486c5840817614f2dc2592ed325aa40.tar.gz
upgraded to 1.5.4
removed libimf.so
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01ec02234675..c4fee4e97fc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = julia-mkl
pkgdesc = High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)
- pkgver = 1.5.3
+ pkgver = 1.5.4
pkgrel = 1
epoch = 2
url = https://julialang.org/
@@ -10,7 +10,6 @@ pkgbase = julia-mkl
makedepends = gcc-fortran
makedepends = gmp
makedepends = python
- makedepends = intel-common-libs
makedepends = llvm10
depends = fftw
depends = hicolor-icon-theme
@@ -28,9 +27,9 @@ pkgbase = julia-mkl
conflicts = julia
conflicts = julia-git
backup = etc/julia/startup.jl
- source = https://github.com/JuliaLang/julia/releases/download/v1.5.3/julia-1.5.3-full.tar.gz
+ source = https://github.com/JuliaLang/julia/releases/download/v1.5.4/julia-1.5.4-full.tar.gz
source = make-install-no-build.patch
- sha256sums = fb69337ca037576758547c7eed9ae8f153a9c052318327b6b7f1917408c14d91
+ sha256sums = dbfb8cd544b223eff70f538da7bb9d5b6f76fd0b00dd2385e6254e74ad4e892f
sha256sums = 0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7
pkgname = julia-mkl
diff --git a/PKGBUILD b/PKGBUILD
index 2c353b500cb1..2e42ad8bcdc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,21 @@
pkgname=julia-mkl
_pkgname=julia
epoch=2
-pkgver=1.5.3
+pkgver=1.5.4
pkgrel=1
arch=(x86_64)
pkgdesc='High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)'
url='https://julialang.org/'
license=(MIT)
depends=(fftw hicolor-icon-theme intel-mkl libgit2 libunwind libutf8proc suitesparse mbedtls openlibm pcre2 llvm10-libs)
-makedepends=(cmake gcc-fortran gmp python intel-common-libs llvm10)
+makedepends=(cmake gcc-fortran gmp python llvm10)
optdepends=('gnuplot: If using the Gaston Package from julia')
provides=('julia')
conflicts=('julia' 'julia-git')
backup=(etc/julia/startup.jl)
source=("https://github.com/JuliaLang/julia/releases/download/v$pkgver/$_pkgname-$pkgver-full.tar.gz"
make-install-no-build.patch)
-sha256sums=('fb69337ca037576758547c7eed9ae8f153a9c052318327b6b7f1917408c14d91'
+sha256sums=('dbfb8cd544b223eff70f538da7bb9d5b6f76fd0b00dd2385e6254e74ad4e892f'
'0b57e0bc6e25c92fde8a6474394f7a99bfb57f9b5d0f7b53f988622ae67de8b7')
prepare() {
@@ -31,6 +31,8 @@ prepare() {
# Don't build again in install
patch -p1 -i ../make-install-no-build.patch
+
+ sed -e '/libimf/d' -e 's/-limf//' -i Make.inc
}
build() {