summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2021-04-25 01:37:31 +0800
committerJingbei Li2021-04-25 01:39:10 +0800
commit75618ac2c90e6b73d20ccb89e3db6f94cd86eb90 (patch)
tree602fda9f615a1d284d83c622a1be3242cd380b86
parent56c7f1c4505e6f8bdc333314682830a0bba4ff80 (diff)
downloadaur-75618ac2c90e6b73d20ccb89e3db6f94cd86eb90.tar.gz
use intel libm
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 365a5106deb7..50674c3d3a58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = julia-mkl
pkgdesc = High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)
pkgver = 1.6.1
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://julialang.org/
arch = x86_64
@@ -15,12 +15,12 @@ pkgbase = julia-mkl
depends = fftw
depends = hicolor-icon-theme
depends = intel-mkl
+ depends = intel-oneapi-compiler-shared
depends = libgit2
depends = libunwind
depends = libutf8proc
depends = suitesparse
depends = mbedtls
- depends = openlibm
depends = pcre2
depends = llvm-libs
depends = p7zip
diff --git a/PKGBUILD b/PKGBUILD
index 230c238f1ecc..86a1321f55e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@ pkgname=julia-mkl
_pkgname=julia
epoch=2
pkgver=1.6.1
-pkgrel=1
+pkgrel=2
arch=(x86_64)
pkgdesc='High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)'
url='https://julialang.org/'
license=(MIT)
-depends=(fftw hicolor-icon-theme intel-mkl libgit2 libunwind libutf8proc suitesparse mbedtls openlibm pcre2 llvm-libs p7zip)
+depends=(fftw hicolor-icon-theme intel-mkl intel-oneapi-compiler-shared libgit2 libunwind libutf8proc suitesparse mbedtls pcre2 llvm-libs p7zip)
makedepends=(cmake gcc-fortran gmp python llvm patchelf)
optdepends=('gnuplot: If using the Gaston Package from julia')
provides=('julia')
@@ -37,8 +37,6 @@ prepare() {
patch -p1 -i ../make-install-no-build.patch
# Fix test failure
sed -e 's|0.22314355f0 + 3.1415927f0im|0.22314355f0 - 3.1415927f0im|' -i stdlib/LinearAlgebra/test/lu.jl
- # Remove libimf.so
- sed -e '/libimf/d' -e 's/-limf//' -i Make.inc
}
_buildopts="prefix=/usr \
@@ -67,7 +65,6 @@ _buildopts="prefix=/usr \
USE_SYSTEM_PATCHELF=1 \
USE_SYSTEM_ZLIB=1 \
USE_SYSTEM_P7ZIP=1 \
- USE_SYSTEM_OPENLIBM=1 \
MARCH=x86-64"
build() {