summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorisrael.herraiz2017-06-28 22:04:52 +0200
committerisrael.herraiz2017-06-28 22:04:52 +0200
commit7b1101f4ee700cddc2028c2f84282138820ef37f (patch)
tree0a147c22f489eac0fc1f7e969d3b00d666127e7d
parent122570f64e0e3879a40ea9e4081a30be908dac9f (diff)
downloadaur-7b1101f4ee700cddc2028c2f84282138820ef37f.tar.gz
Update to Julia 0.6.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
-rw-r--r--julia-libunwind-version.patch15
3 files changed, 41 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7237c92cb0af..3e827152227f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = julia-mkl
pkgdesc = High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)
- pkgver = 0.5.2
+ pkgver = 0.6.0
pkgrel = 1
url = http://julialang.org/
arch = x86_64
@@ -19,12 +19,15 @@ pkgbase = julia-mkl
makedepends = intel-compiler-base
makedepends = intel-fortran-compiler
makedepends = libgit2
+ makedepends = llvm
conflicts = julia-git
conflicts = julia
options = !emptydirs
options = staticlibs
- source = https://github.com/JuliaLang/julia/releases/download/v0.5.2/julia-0.5.2.tar.gz
- md5sums = 9a80cd43a07790bde8f159e8ce79187b
+ source = https://github.com/JuliaLang/julia/releases/download/v0.6.0/julia-0.6.0.tar.gz
+ source = julia-libunwind-version.patch
+ sha256sums = 1c62bfce8075acf2b5b02355520a61210690324eceb021030681459d18a3a665
+ sha256sums = 16009ce454f58463464027cbaf6186ccfab84c37660a52fb1ec3a0f514df64f9
pkgname = julia-mkl
install = sysfix.install
diff --git a/PKGBUILD b/PKGBUILD
index 83be8eb6b338..5ace659b5870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,34 @@
pkgbase=julia-mkl
pkgname=('julia-mkl' 'julia-mkl-docs')
-pkgver=0.5.2
+pkgver=0.6.0
pkgrel=1
arch=('x86_64')
pkgdesc='High-level, high-performance, dynamic programming language (compiled with the Intel MKL library)'
url='http://julialang.org/'
license=('MIT')
-makedepends=('python2' 'libuv' 'libunwind' 'mpfr' 'zlib' 'suitesparse-mkl' 'patchelf' 'cmake' 'pcre2' 'openssl' 'intel-mkl' 'intel-compiler-base' 'intel-fortran-compiler' 'libgit2')
+makedepends=('python2' 'libuv' 'libunwind' 'mpfr' 'zlib' 'suitesparse-mkl' 'patchelf' 'cmake' 'pcre2' 'openssl' 'intel-mkl' 'intel-compiler-base' 'intel-fortran-compiler' 'libgit2' 'llvm')
options=('!emptydirs' 'staticlibs')
-source=("https://github.com/JuliaLang/julia/releases/download/v$pkgver/julia-$pkgver.tar.gz")
-md5sums=('9a80cd43a07790bde8f159e8ce79187b')
+source=("https://github.com/JuliaLang/julia/releases/download/v$pkgver/julia-$pkgver.tar.gz" julia-libunwind-version.patch)
+sha256sums=('1c62bfce8075acf2b5b02355520a61210690324eceb021030681459d18a3a665'
+ '16009ce454f58463464027cbaf6186ccfab84c37660a52fb1ec3a0f514df64f9')
conflicts=('julia-git' 'julia')
prepare() {
# For /etc/ld.so.conf.d/
echo '/usr/lib/julia' > julia.conf
+
+ cd julia-$pkgver
+ patch -p1 -i ../julia-libunwind-version.patch
}
build() {
- source /opt/intel/mkl/bin/mklvars.sh intel64
+
source /opt/intel/composerxe/linux/bin/compilervars.sh intel64
+ source /opt/intel/composerxe/linux/bin/iccvars.sh intel64
+ source /opt/intel/composerxe/linux/bin/ifortvars.sh intel64
+ source /opt/intel/mkl/bin/mklvars.sh intel64
make -C julia-$pkgver prefix=/usr sysconfdir=/etc \
USEICC=1 \
@@ -35,7 +42,8 @@ build() {
USE_SYSTEM_PCRE=1 \
USE_SYSTEM_LIBGIT2=1 \
USE_SYSTEM_PATCHELF=1 \
- USE_SYSTEM_SUITESPARSE=1
+ USE_SYSTEM_SUITESPARSE=1 \
+ USE_SYSTEM_LLVM=1
}
package_julia-mkl() {
@@ -44,9 +52,11 @@ package_julia-mkl() {
optdepends=('gnuplot: If using the Gaston Package from julia')
install='sysfix.install'
- source /opt/intel/mkl/bin/mklvars.sh intel64
source /opt/intel/composerxe/linux/bin/compilervars.sh intel64
-
+ source /opt/intel/composerxe/linux/bin/iccvars.sh intel64
+ source /opt/intel/composerxe/linux/bin/ifortvars.sh intel64
+ source /opt/intel/mkl/bin/mklvars.sh intel64
+
make -C julia-$pkgver DESTDIR="$pkgdir" \
prefix=/usr sysconfdir=/etc \
USEICC=1 \
@@ -55,11 +65,12 @@ package_julia-mkl() {
USE_INTEL_MKL_FFT=1 \
USE_INTEL_LIBM=1 \
USE_SYSTEM_CURL=1 \
- USE_SYSTEM_LIBUNWIND=1 \
+ USE_SYSTEM_LIBUNWIND=1\
USE_SYSTEM_PCRE=1 \
USE_SYSTEM_LIBGIT2=1 \
USE_SYSTEM_PATCHELF=1 \
USE_SYSTEM_SUITESPARSE=1 \
+ USE_SYSTEM_LLVM=1 \
install
# Remove duplicate man-page from julia/doc
diff --git a/julia-libunwind-version.patch b/julia-libunwind-version.patch
new file mode 100644
index 000000000000..f3e3cd60e876
--- /dev/null
+++ b/julia-libunwind-version.patch
@@ -0,0 +1,15 @@
+--- julia-0.6.0/src/julia_internal.h.0 2017-06-25 16:10:29.688382943 +0000
++++ julia-0.6.0/src/julia_internal.h 2017-06-25 16:11:15.328315342 +0000
+@@ -643,11 +643,8 @@
+ typedef unw_context_t bt_context_t;
+ typedef unw_cursor_t bt_cursor_t;
+-# if (!defined(SYSTEM_LIBUNWIND) || UNW_VERSION_MAJOR > 1 || \
+- (UNW_VERSION_MAJOR == 1 && UNW_VERSION_MINOR > 1))
+ // Enable our memory manager only for libunwind with our patch or
+ // on a newer release
+ # define JL_UNW_HAS_FORMAT_IP 1
+-# endif
+ #endif
+ size_t rec_backtrace(uintptr_t *data, size_t maxsize);
+ size_t rec_backtrace_ctx(uintptr_t *data, size_t maxsize, bt_context_t *ctx);
+