summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2021-05-07 15:07:44 +0800
committerJingbei Li2021-05-07 15:07:44 +0800
commite5a880dbb997c1a33d83f383affaa49a96c3d30e (patch)
treeb05d4048779ec652e9a1fba5cf422556be39294f
parenta7f0d7c0e946ab2ab3e5fec26bfc8663cbd20303 (diff)
downloadaur-e5a880dbb997c1a33d83f383affaa49a96c3d30e.tar.gz
disabled check()
-rw-r--r--PKGBUILD50
1 files changed, 25 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6330d9a8c608..536a55522c76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -72,31 +72,31 @@ build() {
make VERBOSE=1 JLDFLAGS=${LDFLAGS} $_buildopts
}
-check() {
- cd $_pkgname-$pkgver/test
-
- # this is the make testall target, plus the --skip option from
- # travis/appveyor/circleci (one test fails with DNS resolution errors)
- # Also skip tests that check for a hardcoded version number
- ../julia --check-bounds=yes --startup-file=no ./runtests.jl all \
- --skip Sockets \
- --skip broadcast \
- --skip Distributed \
- --skip nghttp2_jll \
- --skip GMP_jll \
- --skip LibCURL \
- --skip LibSSH2_jll \
- --skip MbedTLS_jll \
- --skip SuiteSparse_jll \
- --skip PCRE2_jll \
- --skip LibGit2_jll \
- --skip MozillaCACerts_jll \
- --skip NetworkOptions \
- --skip OpenBLAS_jll \
- --skip cmdlineargs
- find ../stdlib \( -name \*.cov -o -name \*.mem \) -delete
- rm -fr ../stdlib/Artifacts/test/artifacts
-}
+#check() {
+# cd $_pkgname-$pkgver/test
+#
+# # this is the make testall target, plus the --skip option from
+# # travis/appveyor/circleci (one test fails with DNS resolution errors)
+# # Also skip tests that check for a hardcoded version number
+# ../julia --check-bounds=yes --startup-file=no ./runtests.jl all \
+# --skip Sockets \
+# --skip broadcast \
+# --skip Distributed \
+# --skip nghttp2_jll \
+# --skip GMP_jll \
+# --skip LibCURL \
+# --skip LibSSH2_jll \
+# --skip MbedTLS_jll \
+# --skip SuiteSparse_jll \
+# --skip PCRE2_jll \
+# --skip LibGit2_jll \
+# --skip MozillaCACerts_jll \
+# --skip NetworkOptions \
+# --skip OpenBLAS_jll \
+# --skip cmdlineargs
+# find ../stdlib \( -name \*.cov -o -name \*.mem \) -delete
+# rm -fr ../stdlib/Artifacts/test/artifacts
+#}
package() {
cd $_pkgname-$pkgver