summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-11-25 00:02:49 +0000
committerJonathon Fernyhough2018-11-25 00:02:49 +0000
commitdef38eaa56469a61a9bdcb0e98d8677acdd110cc (patch)
treee523198b10e99968a0df9e6950d84f0b96ccaf21
downloadaur-def38eaa56469a61a9bdcb0e98d8677acdd110cc.tar.gz
Initial commit of release 1.0.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1caa46221618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = julia-orderedcollections
+ pkgdesc = Julia implementation of associative containers that preserve insertion order
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/JuliaCollections/OrderedCollections.jl
+ arch = any
+ license = MIT
+ depends = julia
+ source = julia-orderedcollections-1.0.2.tar.gz::https://github.com/JuliaCollections/OrderedCollections.jl/archive/v1.0.2.tar.gz
+ sha256sums = 33d4e568f7cbffe9187d7548e86487f375ec0be07fa0da3743a2e008a8453707
+
+pkgname = julia-orderedcollections
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe58ffb4d508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot_org>
+
+pkgname=julia-orderedcollections
+_pkgname=OrderedCollections
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Julia implementation of associative containers that preserve insertion order '
+arch=(any)
+url="https://github.com/JuliaCollections/OrderedCollections.jl"
+license=(MIT)
+depends=(julia)
+
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha256sums=('33d4e568f7cbffe9187d7548e86487f375ec0be07fa0da3743a2e008a8453707')
+
+package() {
+ cd $_pkgname.jl-$pkgver
+ install -dm755 $pkgdir/usr/share/julia/environments/v1.0/$_pkgname
+ cp -r {src,test} $pkgdir/usr/share/julia/environments/v1.0/$_pkgname/
+}
+
+check() {
+ cd $_pkgname.jl-$pkgver
+ JULIA_LOAD_PATH=src:$JULIA_LOAD_PATH julia test/runtests.jl
+}