summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-09-02 17:03:21 +0100
committerJonathon Fernyhough2018-09-02 17:03:21 +0100
commitb3942da9ae8053d579992a7f2a0d61f5b037c4c4 (patch)
treea46dc1c9bdd4db542dc5e0dafcb6f584c41d34ab
downloadaur-b3942da9ae8053d579992a7f2a0d61f5b037c4c4.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0475b00a5a58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = julia-primes
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/JuliaMath/Primes.jl
+ arch = any
+ license = MIT
+ depends = julia
+ depends = julia-compat
+ depends = julia-datastructures
+ source = julia-primes-0.4.0.tar.gz::https://github.com/JuliaMath/Primes.jl/archive/v0.4.0.tar.gz
+ sha256sums = 489f5c77fc2fceb00b2d8c2571b1e85808322c8e762a5d1712e8bfbfb3c8bc36
+
+pkgname = julia-primes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2fd488ff0ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot_org>
+
+pkgname=julia-primes
+_pkgname=Primes
+pkgver=0.4.0
+pkgrel=1
+arch=(any)
+url=https://github.com/JuliaMath/Primes.jl
+license=(MIT)
+depends=(julia julia-compat julia-datastructures)
+
+source=($pkgname-$pkgver.tar.gz::https://github.com/JuliaMath/$_pkgname.jl/archive/v$pkgver.tar.gz)
+sha256sums=('489f5c77fc2fceb00b2d8c2571b1e85808322c8e762a5d1712e8bfbfb3c8bc36')
+
+package() {
+ cd $_pkgname.jl-$pkgver
+ install -dm755 $pkgdir/usr/share/julia/environments/v1.0/$_pkgname
+ cp -r {src,test} $pkgdir/usr/share/julia/environments/v1.0/$_pkgname/
+}
+
+check() {
+ cd $_pkgname.jl-$pkgver
+ JULIA_LOAD_PATH=src:$JULIA_LOAD_PATH julia test/runtests.jl
+}