summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNOGISAKA Sadata2015-06-09 22:52:17 +0900
committerNOGISAKA Sadata2015-06-09 22:52:17 +0900
commit655c7b59da6c5e66506a6f3f27f8d1ba91b75ee5 (patch)
tree238f842436bd0bffc8566289e4011b1b131d833b
downloadaur-655c7b59da6c5e66506a6f3f27f8d1ba91b75ee5.tar.gz
initial import
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD27
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b74c108a5025
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = juman
+ pkgdesc = Morphological Analyzer for Japanese
+ pkgver = 7.01
+ pkgrel = 1
+ url = http://nlp.ist.i.kyoto-u.ac.jp/index.php?JUMAN
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://nlp.ist.i.kyoto-u.ac.jp/nl-resource/juman/juman-7.01.tar.bz2
+ sha1sums = e22eb113f40216b8a04d811484a94f93f834ae9a
+
+pkgname = juman
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9adf581f4c73
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a05c9892eec2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: nosada <ngsksdt@gmail.com>
+
+pkgname=juman
+pkgver=7.01
+pkgrel=1
+pkgdesc="Morphological Analyzer for Japanese"
+url="http://nlp.ist.i.kyoto-u.ac.jp/index.php?JUMAN"
+arch=('i686' 'x86_64')
+license=('custom')
+source=(http://nlp.ist.i.kyoto-u.ac.jp/nl-resource/juman/${pkgname}-${pkgver}.tar.bz2)
+sha1sums=('e22eb113f40216b8a04d811484a94f93f834ae9a')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr
+ make ${MAKEFLAGS}
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}
+
+# vim:set ts=2 sw=2 et: