summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRONTheCookie2019-04-11 13:22:26 +0300
committerRONTheCookie2019-04-11 13:22:26 +0300
commit44d10663a78eb27d07ba88cdf3fb92b5c1b06ebd (patch)
treec762a2396a6d5203139b3ad321ed749d3ee4144c
downloadaur-44d10663a78eb27d07ba88cdf3fb92b5c1b06ebd.tar.gz
Inital Commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--0001-Add-shebang-line.patch20
-rw-r--r--PKGBUILD28
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7227df6c729a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = jumpcutter-git
+ pkgdesc = Automatically edits videos. Explanation here: https://www.youtube.com/watch?v=DQ8orIurGxw
+ pkgver = r18.df41c43
+ pkgrel = 1
+ url = https://github.com/carykh/jumpcutter
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = ffmpeg
+ depends = python-pillow
+ depends = python-audiotsm
+ depends = python-scipy
+ depends = python-numpy
+ depends = python
+ source = jumpcutter-git::git+https://github.com/carykh/jumpcutter.git
+ source = 0001-Add-shebang-line.patch
+ sha256sums = SKIP
+ sha256sums = 33c22ce87b48e0d08081da6543f7f7610fcae4240b95d91e285a49339e601ffb
+
+pkgname = jumpcutter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ca6a262bf1cb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+jumpcutter-git
+*.tar.* \ No newline at end of file
diff --git a/0001-Add-shebang-line.patch b/0001-Add-shebang-line.patch
new file mode 100644
index 000000000000..d8874b6acd14
--- /dev/null
+++ b/0001-Add-shebang-line.patch
@@ -0,0 +1,20 @@
+From e25a0360d3b4c8b21863689c2716477e5b02df45 Mon Sep 17 00:00:00 2001
+From: RONTheCookie <ronthecookie0101@gmail.com>
+Date: Thu, 11 Apr 2019 12:52:28 +0300
+Subject: [PATCH] Add shebang line
+
+---
+ jumpcutter.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/jumpcutter.py b/jumpcutter.py
+index 8b59e3d..1fba6f3 100644
+--- a/jumpcutter.py
++++ b/jumpcutter.py
+@@ -1,3 +1,4 @@
++#!/usr/bin/env python
+ from contextlib import closing
+ from PIL import Image
+ import subprocess
+--
+2.21.0
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e78ea6882c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ron B.S <ronthecookie0101 on gmail --OR-- me AT ronthecookie DOT me
+pkgname=jumpcutter-git
+pkgver=r18.df41c43
+pkgrel=1
+pkgdesc="Automatically edits videos. Explanation here: https://www.youtube.com/watch?v=DQ8orIurGxw"
+arch=('any')
+url="https://github.com/carykh/jumpcutter"
+license=('MIT')
+depends=('ffmpeg' 'python-pillow' 'python-audiotsm' 'python-scipy' 'python-numpy' 'python')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/carykh/jumpcutter.git" '0001-Add-shebang-line.patch')
+sha256sums=('SKIP'
+ '33c22ce87b48e0d08081da6543f7f7610fcae4240b95d91e285a49339e601ffb')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+prepare() {
+ cd "$srcdir/$pkgname"
+ git am < $srcdir/0001-Add-shebang-line.patch
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 jumpcutter.py "$pkgdir"/usr/bin/jumpcutter
+}