summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2015-12-14 14:05:34 +0100
committermirandir2015-12-14 14:05:34 +0100
commit1c540082eb99e7e64dd90469067f3587f70399a3 (patch)
treee35f45145f7a386be6ad3c4fcb8494348492c98f
parentff28187dd67f5a7c96203556513db7d7ad150ef3 (diff)
downloadaur-1c540082eb99e7e64dd90469067f3587f70399a3.tar.gz
Patches updates
-rw-r--r--.SRCINFO8
-rw-r--r--NetPacket_buffer_size.patch4
-rw-r--r--PKGBUILD10
-rw-r--r--makefile.patch32
-rw-r--r--no-springs.patch15
5 files changed, 40 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87d1cfd88798..e00f4d075ae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jumpnbump
pkgdesc = You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port.
pkgver = 1.60
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MCMic/jumpnbump
arch = i686
arch = x86_64
@@ -18,11 +18,11 @@ pkgbase = jumpnbump
source = safe-temporary-files.patch
source = NetPacket_buffer_size.patch
sha256sums = SKIP
- sha256sums = deaaa6b6ffbeca4988cbe140c1099073b0939c9665f3092c865a3185b1eafcb8
+ sha256sums = 68b8df05a9f3cb6fa4584570c0558cdd23e43bc822fd8a53d708900bdc23ef01
sha256sums = c883804700bcaf602bdec6882fefe945519e18dfc430f05cffca34ec86c81290
- sha256sums = 9abb6eacbdc964575de1219467e376737c2d67b79c43c0ac8f2a17ab55cfea2c
+ sha256sums = c6d795f3c5d0a174dfe6f2e528d70246d75181ffa3f652386c2f8b2b84657ce9
sha256sums = f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c
- sha256sums = db10c56f0183177e02da83e4277b4cff4637b67a8a354fa7981a519a90ee7ba9
+ sha256sums = 521317ed06d957fb0e3a509e93976ec52709e6f2a16ea121d3767f871605a485
pkgname = jumpnbump
diff --git a/NetPacket_buffer_size.patch b/NetPacket_buffer_size.patch
index cecb1d9ec384..1959be8626a6 100644
--- a/NetPacket_buffer_size.patch
+++ b/NetPacket_buffer_size.patch
@@ -1,3 +1,7 @@
+Subject: Fix NetPacket buffer size by adapting its member types
+Author: Fabian Greffrath <fabian+debian@greffrath.com>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762698
+
--- network.h.orig 2015-12-13 02:08:25.346244000 +0100
+++ network.h 2015-12-13 02:09:56.248672920 +0100
@@ -51,11 +51,11 @@
diff --git a/PKGBUILD b/PKGBUILD
index 3990e0615412..d8bd56d1caf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=jumpnbump
pkgver=1.60
-pkgrel=1
+pkgrel=2
pkgdesc="You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port."
arch=('i686' 'x86_64')
url="https://github.com/MCMic/jumpnbump"
@@ -13,11 +13,11 @@ depends=('sdl2' 'sdl2_mixer' 'sdl2_net')
optdepends=('jumpnbump-levels: more levels for jumpnbump' 'jumpnbump-menu: a launcher for jumpnbump')
source=(jumpnbump::git+https://github.com/MCMic/jumpnbump#commit=28fc03e makefile.patch format-security.patch no-springs.patch safe-temporary-files.patch NetPacket_buffer_size.patch)
sha256sums=('SKIP'
- 'deaaa6b6ffbeca4988cbe140c1099073b0939c9665f3092c865a3185b1eafcb8'
+ '68b8df05a9f3cb6fa4584570c0558cdd23e43bc822fd8a53d708900bdc23ef01'
'c883804700bcaf602bdec6882fefe945519e18dfc430f05cffca34ec86c81290'
- '9abb6eacbdc964575de1219467e376737c2d67b79c43c0ac8f2a17ab55cfea2c'
+ 'c6d795f3c5d0a174dfe6f2e528d70246d75181ffa3f652386c2f8b2b84657ce9'
'f99113c04b988d2e2048b79bb58bfeba26b3aeea3937936b97b06334d34a5c4c'
- 'db10c56f0183177e02da83e4277b4cff4637b67a8a354fa7981a519a90ee7ba9')
+ '521317ed06d957fb0e3a509e93976ec52709e6f2a16ea121d3767f871605a485')
build() {
cd "${srcdir}/${pkgname}/"
@@ -35,7 +35,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}"
- make PREFIX="${pkgdir}" install
+ make PREFIX="${pkgdir}/usr/" install
install -d $pkgdir/usr/lib/jumpnbump
mv $pkgdir/usr/bin/gobpack $pkgdir/usr/lib/jumpnbump/gobpack
diff --git a/makefile.patch b/makefile.patch
index 551d615275d5..6dcf6a9cb420 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2015-12-12 12:31:26.850930000 +0100
-+++ Makefile 2015-12-12 12:33:25.507572377 +0100
+--- Makefile.orig 2015-12-14 13:43:24.760324000 +0100
++++ Makefile 2015-12-14 13:47:51.211541498 +0100
@@ -10,7 +10,7 @@
TARGET = jumpnbump
BINARIES = $(TARGET) jumpnbump.svgalib jumpnbump.fbcon $(MODIFY_TARGET) \
@@ -9,32 +9,24 @@
.PHONY: data
-@@ -43,18 +43,18 @@
+@@ -43,16 +43,16 @@
rm -f $(TARGET) *.o globals.h jnbmenu.tcl
install:
- mkdir -p $(PREFIX)/games/
-- mkdir -p $(PREFIX)/share/jumpnbump/
-- mkdir -p $(PREFIX)/share/man/man6/
++ mkdir -p $(PREFIX)/bin/
+ mkdir -p $(PREFIX)/share/jumpnbump/
+ mkdir -p $(PREFIX)/share/man/man6/
- install -o root -g games -m 755 $(BINARIES) $(PREFIX)/games/
- install -o root -g games -m 644 data/jumpbump.dat \
-- $(PREFIX)/share/jumpnbump/jumpbump.dat
-- install -o root -g root -m 644 jumpnbump.6 $(PREFIX)/share/man/man6/
-+ mkdir -p $(PREFIX)/usr/bin/
-+ mkdir -p $(PREFIX)/usr/share/jumpnbump/
-+ mkdir -p $(PREFIX)/usr/share/man/man6/
-+ install -o root -g root -m 755 $(BINARIES) $(PREFIX)/usr/bin/
++ install -o root -g root -m 755 $(BINARIES) $(PREFIX)/bin/
+ install -o root -g root -m 644 data/jumpbump.dat \
-+ $(PREFIX)/usr/share/jumpnbump/jumpbump.dat
-+ install -o root -g root -m 644 jumpnbump.6 $(PREFIX)/usr/share/man/man6/
+ $(PREFIX)/share/jumpnbump/jumpbump.dat
+ install -o root -g root -m 644 jumpnbump.6 $(PREFIX)/share/man/man6/
uninstall:
- cd $(PREFIX)/games && rm -f $(BINARIES)
-- rm -rf $(PREFIX)/share/jumpnbump
-- rm -f $(PREFIX)/share/man/man6/jumpnbump.6
-+ cd $(PREFIX)/usr/bin/ && rm -f $(BINARIES)
-+ rm -rf $(PREFIX)/usr/share/jumpnbump
-+ rm -f $(PREFIX)/usr/share/man/man6/jumpnbump.6
++ cd $(PREFIX)/bin/ && rm -f $(BINARIES)
+ rm -rf $(PREFIX)/share/jumpnbump
+ rm -f $(PREFIX)/share/man/man6/jumpnbump.6
- doc:
- rman jumpnbump.6 -f HTML >jumpnbump.html
diff --git a/no-springs.patch b/no-springs.patch
index 0e0c4ec9f823..468cd211a5b7 100644
--- a/no-springs.patch
+++ b/no-springs.patch
@@ -1,3 +1,18 @@
+From 4a0a965547b52afc953d9bd11ab059f543551459 Mon Sep 17 00:00:00 2001
+From: Fabian Greffrath <fabian@greffrath.com>
+Date: Tue, 16 Sep 2014 19:02:37 +0200
+Subject: [PATCH] fix rabbit disappearing in upper left corner
+
+aka "undesired springs added above the screen"
+
+If the bunny jumps out of the screen, its
+y-coordinate becomes negative. Thus, the array that is checked for the
+position of the objects on the map overflows and returns some bogus,
+e.g. that there are springs whereas there aren't. This patch
+checks for the y-coordinate and caps it at zero.
+
+c.f. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370650
+
--- main.c.orig 2015-12-12 14:28:44.122453000 +0100
+++ main.c 2015-12-12 14:35:47.141659120 +0100
@@ -1365,6 +1365,8 @@