summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2020-08-16 15:26:26 +0200
committermirandir2020-08-16 15:26:26 +0200
commit43844153f7ee71b57907f6c900a4b487829b63ff (patch)
tree5d7bfc338f413700bb34552204b08ba65851c9f7
parent1006435575e9271df50147c181822b5badf62916 (diff)
downloadaur-43844153f7ee71b57907f6c900a4b487829b63ff.tar.gz
Fix build failure with GCC 10
-rwxr-xr-x.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--b72b70a4233776bdaa6a683c89af2becefd53bd6.diff67
3 files changed, 77 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0aaf555a1ff..546c45512890 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jumpnbump
pkgdesc = You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port.
pkgver = 1.61
- pkgrel = 2
+ pkgrel = 3
url = https://libregames.gitlab.io/jumpnbump/
arch = i686
arch = x86_64
@@ -17,9 +17,11 @@ pkgbase = jumpnbump
source = https://gitlab.com/LibreGames/jumpnbump/uploads/95acdae2a232513f068e260977371dcf/jumpnbump-1.61.tar.xz
source = menu.patch
source = desktop.patch
+ source = b72b70a4233776bdaa6a683c89af2becefd53bd6.diff
sha256sums = 6a81300336cc4616d8343f65bea6776cf3d71862e50b5d08dab52a46da58d7ad
sha256sums = c779543e05f954886d6ef3a3a8e552358e3590b8c8416fe29dbdf022a613fc13
sha256sums = 03f21c44bb5c930f3da1d9b532b95395a587a7c4e9e80b235f964fb15971edb9
+ sha256sums = 60adc26e959b161ff22a459ff849f11c87033bd36a501269f4a23826c5238bc7
pkgname = jumpnbump
diff --git a/PKGBUILD b/PKGBUILD
index 302f5b8d0a93..d17bcad1ceee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=jumpnbump
pkgver=1.61
-pkgrel=2
+pkgrel=3
pkgdesc="You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign. SDL2 port."
arch=('i686' 'x86_64')
url="https://libregames.gitlab.io/jumpnbump/"
@@ -12,12 +12,16 @@ license=('GPL')
depends=('sdl2' 'sdl2_mixer' 'sdl2_net' 'gtk3' 'python' 'python-gobject')
optdepends=('jumpnbump-levels: more levels for jumpnbump')
conflicts=('jumpnbump-menu')
-source=(https://gitlab.com/LibreGames/jumpnbump/uploads/95acdae2a232513f068e260977371dcf/jumpnbump-${pkgver}.tar.xz menu.patch desktop.patch)
+source=(https://gitlab.com/LibreGames/jumpnbump/uploads/95acdae2a232513f068e260977371dcf/jumpnbump-${pkgver}.tar.xz menu.patch desktop.patch b72b70a4233776bdaa6a683c89af2becefd53bd6.diff)
sha256sums=('6a81300336cc4616d8343f65bea6776cf3d71862e50b5d08dab52a46da58d7ad'
'c779543e05f954886d6ef3a3a8e552358e3590b8c8416fe29dbdf022a613fc13'
- '03f21c44bb5c930f3da1d9b532b95395a587a7c4e9e80b235f964fb15971edb9')
+ '03f21c44bb5c930f3da1d9b532b95395a587a7c4e9e80b235f964fb15971edb9'
+ '60adc26e959b161ff22a459ff849f11c87033bd36a501269f4a23826c5238bc7')
build() {
+ cd $srcdir/${pkgname}-${pkgver}/
+ patch < ../b72b70a4233776bdaa6a683c89af2becefd53bd6.diff
+
cd $srcdir/${pkgname}-${pkgver}/menu
patch -p0 < ../../../menu.patch || return 1
diff --git a/b72b70a4233776bdaa6a683c89af2becefd53bd6.diff b/b72b70a4233776bdaa6a683c89af2becefd53bd6.diff
new file mode 100644
index 000000000000..aafccb7fdf79
--- /dev/null
+++ b/b72b70a4233776bdaa6a683c89af2becefd53bd6.diff
@@ -0,0 +1,67 @@
+diff --git a/Makefile b/Makefile
+index 51f7542708d140e060eee76d2b6c2293a7ff766c..077cc520319975edd7463dc64f5b6a1208d1c442 100644
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@ DATADIR ?= $(PREFIX)/share
+ GAMEDATADIR ?= $(DATADIR)
+ EXE ?=
+
+-CFLAGS ?= -Wall -O2 -ffast-math -funroll-loops
++CFLAGS ?= -Wall -O2 -ffast-math -funroll-loops -fno-common
+ SDL_CFLAGS = `sdl2-config --cflags`
+ DEFINES = -Dstricmp=strcasecmp -Dstrnicmp=strncasecmp -DNDEBUG -DUSE_SDL -DUSE_NET -DZLIB_SUPPORT -DBZLIB_SUPPORT
+ INCLUDES = -I.
+diff --git a/globals.pre b/globals.pre
+index 0d4a7389daa6282b4bac9a1a1dc8b06abd3962ff..781c8eb578a15ca0d19cb47d83bd5e773c95a853 100644
+--- a/globals.pre
++++ b/globals.pre
+@@ -267,7 +267,7 @@ extern gob_t number_gobs;
+
+ /* main.c */
+
+-int endscore_reached;
++extern int endscore_reached;
+
+ void steer_players(void);
+ void position_player(int player_num);
+diff --git a/main.c b/main.c
+index d03e5f041e5352e33ffd8e52fa2067366729afd1..87b4e95366a9537bc2ebc5c36a31c9223ace9b9e 100644
+--- a/main.c
++++ b/main.c
+@@ -67,6 +67,8 @@ char cur_pal[768];
+
+ int ai[JNB_MAX_PLAYERS];
+
++int endscore_reached = 0;
++
+ unsigned int ban_map[17][22] = {
+ {1, 1, 1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0},
+ {1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 1, 0, 0, 0, 0, 1, 1, 0, 0, 0},
+diff --git a/network.c b/network.c
+index 07227e72c87365ea23c4e43a9e7731ec53e5274c..b4a1e4e9f86a099733f033a19af119ee5df13883 100644
+--- a/network.c
++++ b/network.c
+@@ -32,6 +32,10 @@ int is_server = 1;
+ int is_net = 0;
+ int server_said_bye = 0;
+
++#ifdef USE_NET
++NetInfo net_info[JNB_MAX_PLAYERS];
++#endif
++
+ void processMovePacket(NetPacket *pkt)
+ {
+ int playerid = pkt->arg;
+diff --git a/network.h b/network.h
+index 3058630e718a78582c812d0d1f2b4a31f73f5e3e..f591480e2924980f6fce2531f272bee36d69c5a5 100644
+--- a/network.h
++++ b/network.h
+@@ -74,7 +74,7 @@ typedef struct
+ SDLNet_SocketSet socketset;
+ } NetInfo;
+
+-NetInfo net_info[JNB_MAX_PLAYERS];
++extern NetInfo net_info[JNB_MAX_PLAYERS];
+
+ void bufToPacket(const char *buf, NetPacket *pkt);
+