summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2015-06-08 12:18:44 +0200
committermirandir2015-06-08 12:18:44 +0200
commite1c162e750aa00c4fa4733ed87bbf1d5d3f43f4e (patch)
tree7f88c0104b7c2af1f795c7f16a32ace2b71df7f3
downloadaur-e1c162e750aa00c4fa4733ed87bbf1d5d3f43f4e.tar.gz
AUR4 import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--jnb.patch34
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4274c23fe66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = jumpnbump
+ pkgdesc = You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign.
+ pkgver = 1.55
+ pkgrel = 5
+ url = http://freecode.com/projects/jumpnbump
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_mixer
+ depends = sdl_net
+ optdepends = jumpnbump-levels: more levels for jumpnbump
+ optdepends = jumpnbump-menu: a launcher for jumpnbump
+ source = http://mirandir.pagesperso-orange.fr/files/jumpnbump-1.55.tar.gz
+ source = jnb.patch
+ sha256sums = 95e9ec8c3148a996bd46ffea21393aa0e0868706325d5947bc932b4ba46eafcf
+ sha256sums = 16d4363944d8279e7da77588085f7c103afa743f977c1ea9c742959f6140253d
+
+pkgname = jumpnbump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28e16b6a5c39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: ekse <ekse.0x[AT]gmail[DOT]com>
+# Maintainer: mirandir <mirandir[AT]orange[DOT]fr>
+
+pkgname=jumpnbump
+pkgver=1.55
+pkgrel=5
+pkgdesc="You, as a bunny, have to jump on your opponents to make them explode. It's a true multiplayer game which can't be played alone. It has network support. This program is a Unix port of the old DOS game by brainchilddesign."
+arch=('i686' 'x86_64')
+url="http://freecode.com/projects/jumpnbump"
+license=('GPL')
+depends=('sdl_mixer' 'sdl_net')
+optdepends=('jumpnbump-levels: more levels for jumpnbump' 'jumpnbump-menu: a launcher for jumpnbump')
+source=("http://mirandir.pagesperso-orange.fr/files/${pkgname}-${pkgver}.tar.gz" "jnb.patch")
+sha256sums=('95e9ec8c3148a996bd46ffea21393aa0e0868706325d5947bc932b4ba46eafcf'
+ '16d4363944d8279e7da77588085f7c103afa743f977c1ea9c742959f6140253d')
+
+build() {
+ cd "${srcdir}/${pkgname}-1.50/sdl/"
+ patch -lp0 < ../../jnb.patch || return 1
+
+ cd "${srcdir}/${pkgname}-1.50"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-1.50"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/jnb.patch b/jnb.patch
new file mode 100644
index 000000000000..2daf45f6d367
--- /dev/null
+++ b/jnb.patch
@@ -0,0 +1,34 @@
+--- interrpt.c.orig 2004-06-16 21:03:39.000000000 +0200
++++ interrpt.c 2014-09-12 11:11:21.197959171 +0200
+@@ -369,6 +369,7 @@
+ }
+ break;
+ case SDLK_1:
++ case SDLK_AMPERSAND:
+ if (e.type == SDL_KEYUP)
+ ai[0] = !ai[0];
+
+@@ -378,6 +379,7 @@
+ addkey((KEY_PL1_JUMP & 0x7f) | 0x8000);
+ break;
+ case SDLK_2:
++ case SDLK_WORLD_73:
+ if (e.type == SDL_KEYUP)
+ ai[1] = !ai[1];
+
+@@ -387,6 +389,7 @@
+ addkey((KEY_PL2_JUMP & 0x7f) | 0x8000);
+ break;
+ case SDLK_3:
++ case SDLK_QUOTEDBL:
+ if (e.type == SDL_KEYUP)
+ ai[2] = !ai[2];
+
+@@ -396,6 +399,7 @@
+ addkey((KEY_PL3_JUMP & 0x7f) | 0x8000);
+ break;
+ case SDLK_4:
++ case SDLK_QUOTE:
+ if (e.type == SDL_KEYUP)
+ ai[3] = !ai[3];
+